mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Matthew Wilcox <willy@debian.org>
To: Linus Torvalds <torvalds@osdl.org>
Cc: Andries.Brouwer@cwi.nl, linux-kernel@vger.kernel.org
Subject: [PATCH] Fix XFree86 build
Date: Fri, 14 Nov 2003 20:22:20 +0000	[thread overview]
Message-ID: <20031114202220.GK30485@parcelfarce.linux.theplanet.co.uk> (raw)


Hi Linus.

Andries changed the struct member's name from "period" to "rate"
back in October 2002.  This was great for kernel code, but not so good
when the header is used for userspace (ie the XFree86 build uses it).
The following patch restores the old name for the benefit of userspace.

Index: include/linux/kd.h
===================================================================
RCS file: /var/cvs/linux-2.6/include/linux/kd.h,v
retrieving revision 1.1
diff -u -p -r1.1 kd.h
--- a/include/linux/kd.h	29 Jul 2003 17:02:13 -0000	1.1
+++ b/include/linux/kd.h	14 Nov 2003 20:18:38 -0000
@@ -134,8 +134,11 @@ struct kbkeycode {
 
 struct kbd_repeat {
 	int delay;	/* in msec; <= 0: don't change */
+#ifdef __KERNEL__
 	int period;	/* in msec; <= 0: don't change */
-			/* earlier this field was misnamed "rate" */
+#else
+	int rate;	/* earlier this field was misnamed "rate" */
+#endif
 };
 
 #define KDKBDREP        0x4B52  /* set keyboard delay/repeat rate;

-- 
"It's not Hollywood.  War is real, war is primarily not about defeat or
victory, it is about death.  I've seen thousands and thousands of dead bodies.
Do you think I want to have an academic debate on this subject?" -- Robert Fisk

             reply	other threads:[~2003-11-14 20:22 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2003-11-14 20:22 Matthew Wilcox [this message]
2003-11-14 21:15 Andries.Brouwer

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20031114202220.GK30485@parcelfarce.linux.theplanet.co.uk \
    --to=willy@debian.org \
    --cc=Andries.Brouwer@cwi.nl \
    --cc=linux-kernel@vger.kernel.org \
    --cc=torvalds@osdl.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®