mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: viro@parcelfarce.linux.theplanet.co.uk
To: Giuliano Pochini <pochini@shiny.it>
Cc: Andries Brouwer <aebr@win.tue.nl>,
	linux kernel <linux-kernel@vger.kernel.org>,
	Michael Frank <mhf@linuxmail.org>
Subject: Re: PATCH, RFC: 2.6 Documentation/Codingstyle
Date: Fri, 13 Feb 2004 16:18:34 +0000	[thread overview]
Message-ID: <20040213161834.GC8858@parcelfarce.linux.theplanet.co.uk> (raw)
In-Reply-To: <XFMail.20040213145513.pochini@shiny.it>

On Fri, Feb 13, 2004 at 02:55:13PM +0100, Giuliano Pochini wrote:
> I propose to change "hard limit" to "soft limit" to avoid things like this:
> 
>                                 rc=idefloppy_begin_format(drive, inode,
>                                                               file,
>                                                               (int *)arg);

To avoid such things, we'd better
	a) note that idefloppy_begin_format() ignores its second and third
arguments and thus shouldn't have them at all (done in 2.6)
	b) note that we are within
			if (...) {
				...
				return -EBUSY;
			} else {
				...
				our call
				...
			}
and thus can trim one indent level. (done in 2.6)
	c) note that we are within
		{
			idefloppy_floppy_t *floppy = drive->driver_data;
			...
			our call
			...
		}
and compound operator is needed only to because of that declaration.  At
the same time, we already have
	idefloppy_floppy_t *floppy = drive->driver_data;
in the beginning of function and neither drive nor drive->driver_data can
change between those declarations.  IOW, declaration in the compound
statement can be dropped and statement itself - opened.  (done in 2.6)
	d) note that it's static, so "idefloppy_" prefix is plain and simple
idiocy.
	e) note that
		rc = begin_format(drive, (int *)arg);
fits on the line just fine and is far more readable than crap above, with or
without linewrap.


Next example, please?

While we are at it,
                        if (drive->usage > 1) {
                                /* Don't format if someone is using the disk */
several lines above is broken by design -
	fd = open("/dev/hdc", O_RDWR);
	if (fork() == 0)
		write(fd, big_buffer, sizeof(big_buffer);
	else
		ioctl(fd, IDEFLOPPY_IOCTL_FORMAT_START, &args);
	exit(0);
will cheerfully pass that check and start format while the drive is very much
in use.  Driver (and hardware) will not be happy.

ioctl(2) - Just Say No...

  parent reply	other threads:[~2004-02-13 16:19 UTC|newest]

Thread overview: 44+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2004-02-12 22:15 Michael Frank
2004-02-12 23:20 ` Tim Bird
2004-02-12 23:46   ` Måns Rullgård
2004-02-13  0:19   ` Tim Hockin
2004-02-12 23:38 ` Randy.Dunlap
2004-02-13  1:50   ` Alex Goddard
2004-02-13  1:52   ` Maciej Zenczykowski
2004-02-13  0:13 ` viro
2004-02-13  1:12 ` J. Bruce Fields
2004-02-13  8:49 ` PATCH, RFC: Version 2 of 2.6 Codingstyle Michael Frank
2004-02-13  9:44   ` Andries Brouwer
2004-02-13 11:24     ` Nikita Danilov
2004-02-16 17:56     ` Ludootje
2004-02-13 22:38   ` Randy.Dunlap
2004-02-13  8:58 ` PATCH, RFC: 2.6 Documentation/Codingstyle Giuliano Pochini
2004-02-13  9:10   ` Andrew Morton
2004-02-13  9:49     ` Michael Frank
2004-02-13 10:09       ` Nick Piggin
2004-02-13 10:50         ` Michael Frank
2004-02-18  7:39           ` Miles Bader
2004-02-13 12:44     ` viro
2004-02-13  9:19   ` David Weinehall
2004-02-13 11:42   ` Andries Brouwer
2004-02-13 12:13     ` Måns Rullgård
2004-02-13 12:42     ` Ed Tomlinson
2004-02-13 13:55     ` Giuliano Pochini
2004-02-13 14:35       ` Angelo Dell'Aera
2004-02-13 15:42         ` Giuliano Pochini
2004-02-13 15:48         ` Valdis.Kletnieks
2004-02-13 16:38           ` Angelo Dell'Aera
2004-02-13 17:03             ` Valdis.Kletnieks
2004-02-13 16:18       ` viro [this message]
2004-02-14  0:38 ` Kevin O'Connor
2004-02-14  0:56   ` Valdis.Kletnieks
2004-02-14  1:44 ` PATCH, RFC: Version 3 of 2.6 Codingstyle Michael Frank
2004-02-14  3:44   ` Dmitry Torokhov
2004-02-15 10:09     ` Jamie Lokier
2004-02-14 20:44 ` PATCH, RFC: Version 4 " Michael Frank
2004-02-14 21:27   ` viro
2004-02-16  3:47 ` PATCH, RFC: Version 5 " Michael Frank
     [not found] <fa.fbh88ra.kn8094@ifi.uio.no>
2004-02-13  6:41 ` PATCH, RFC: 2.6 Documentation/Codingstyle Junio C Hamano
2004-02-13  7:18   ` vda
2004-02-13 12:37     ` Maciej Zenczykowski
2004-02-13 13:57       ` vda

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20040213161834.GC8858@parcelfarce.linux.theplanet.co.uk \
    --to=viro@parcelfarce.linux.theplanet.co.uk \
    --cc=aebr@win.tue.nl \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mhf@linuxmail.org \
    --cc=pochini@shiny.it \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®