mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jean Tourrilhes <jt@bougret.hpl.hp.com>
To: "David S. Miller" <davem@redhat.com>,
	Linux kernel mailing list <linux-kernel@vger.kernel.org>,
	irda-users@lists.sourceforge.net, Jeff Garzik <jgarzik@pobox.com>,
	Stephen Hemminger <shemminger@osdl.org>
Subject: IrDA patches : Stephen strikes again !
Date: Tue, 9 Mar 2004 11:03:26 -0800	[thread overview]
Message-ID: <20040309190326.GA14543@bougret.hpl.hp.com> (raw)

	Hi Dave,

	It seems that Stephen will never stop picking fixing the IrDA
stack. He must be addicted. Anyway, here is the result of his latest
work, migrating all the EXPORT_SYMBOL() close to their symbol.
	Those patches are all very trivial and tested here. Would you
mind pushing that to Linus ?

	Regards,

	Jean

-----------------------------------------------------------------------

ir264_irsyms_01_proc.diff :
~~~~~~~~~~~~~~~~~~~~~~~~~
		<Patch from Stephen Hemminger>
(1/14) irda exports proc_irda

Move proc_irda out of irsyms.c into irproc.c

ir264_irsyms_02_irtty.diff
~~~~~~~~~~~~~~~~~~~~~~~~~~
		<Patch from Stephen Hemminger>
(2/14) flush old irtty exports   

These irtty symbols were exported but never used!

ir264_irsyms_03_hashbin.diff :
~~~~~~~~~~~~~~~~~~~~~~~~~~~~
		<Patch from Stephen Hemminger>
(3/14) hashbin export symbols

Move hashbin_X exports out of irsyms and into irqueue.

ir264_irsyms_04_irttp.diff :
~~~~~~~~~~~~~~~~~~~~~~~~~~
		<Patch from Stephen Hemminger>
(4/14) irttp exports

Move irttp_exports out of irsyms

ir264_irsyms_05_irias.diff :
~~~~~~~~~~~~~~~~~~~~~~~~~~
		<Patch from Stephen Hemminger>
(5/14) irias exports

Move iriap_reoutines out of irsyms
Rename variable "missing" to irias_missing

ir264_irsyms_06_irlmp.diff :
~~~~~~~~~~~~~~~~~~~~~~~~~~
		<Patch from Stephen Hemminger>
(6/14) irlmp exports and inline

Move irlmp routines out irsyms.   
Make get_saddr and get_daddr inline
Rename lmp_reasons to irlmp_reasons

ir264_irsyms_07_wrapper.diff :
~~~~~~~~~~~~~~~~~~~~~~~~~~~~
		<Patch from Stephen Hemminger>
(7/14) wrap function exports   

Move async_wrap function exports out of irsyms

ir264_irsyms_08_crc.diff :
~~~~~~~~~~~~~~~~~~~~~~~~
		<Patch from Stephen Hemminger>
(8/14) crc16 symbol exports   

Move crc16 exports out of irsyms. Make type __u16 rather than
unsigned short to match input parameter.

ir264_irsyms_09_timer.diff :
~~~~~~~~~~~~~~~~~~~~~~~~~
		<Patch from Stephen Hemminger>
(9/14) irda_start_timer inline

Make irda_start_timer inline rather than exporting, because
it probably takes more code to call than just put inline

ir264_irsyms_10_irlap.diff :
~~~~~~~~~~~~~~~~~~~~~~~~~~
		<Patch from Stephen Hemminger>
(10/14) irlap symbol exports   

Move irlap exports out of irsyms

ir264_irsyms_11_device-2.diff :
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
		<Patch from Stephen Hemminger>
(11/14) irda_device inlines and symbols   

Make irda_get_mtt, et all inline's not #defines for better
type checking.

irda_device_setup can now be static only called from alloc_irdadev

ir264_irsyms_12_qos.diff :
~~~~~~~~~~~~~~~~~~~~~~~~
		<Patch from Stephen Hemminger>
(12/14) qos symbol exports

Move qos related exports out of irsyms

ir264_irsyms_13_param.diff :
~~~~~~~~~~~~~~~~~~~~~~~~
		<Patch from Stephen Hemminger>
(13/14) irda_param symbol exports

Move irda_param related exports out of irsyms

ir264_irsyms_14_irmod.diff :
~~~~~~~~~~~~~~~~~~~~~~~~~~
		<Original patch from Stephen Hemminger>
(14/14) move last of irsyms.c to irmod.c

Move last bits of code out of irsyms and onto irmod.c where
initialization happens.

Move irda_debug parameter out of irsyms.c into irmod.c
and make it a new style module parameter.

Removes file net/irda/irsyms.c completely; check this in case mailer
seems to barf on the line the character in University of Tromso


             reply	other threads:[~2004-03-09 19:03 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2004-03-09 19:03 Jean Tourrilhes [this message]
2004-03-09 21:43 ` David S. Miller

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20040309190326.GA14543@bougret.hpl.hp.com \
    --to=jt@bougret.hpl.hp.com \
    --cc=davem@redhat.com \
    --cc=irda-users@lists.sourceforge.net \
    --cc=jgarzik@pobox.com \
    --cc=jt@hpl.hp.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=shemminger@osdl.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®