From: Jean Tourrilhes <jt@bougret.hpl.hp.com>
To: "David S. Miller" <davem@redhat.com>,
Linux kernel mailing list <linux-kernel@vger.kernel.org>
Subject: [PATCH 2.6 IrDA] irlan - change handle_filter_request to irlan_filter_request
Date: Wed, 14 Apr 2004 15:19:04 -0700 [thread overview]
Message-ID: <20040414221904.GF5434@bougret.hpl.hp.com> (raw)
irXXX_irlan_handle_filter.diff :
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
<Patch from Stephen Hemminger>
o [FEATURE] Change name of handle_filter_request to
irlan_filter_request to avoid namespace pollution.
diff -Nru a/include/net/irda/irlan_filter.h b/include/net/irda/irlan_filter.h
--- a/include/net/irda/irlan_filter.h Fri Mar 19 11:29:21 2004
+++ b/include/net/irda/irlan_filter.h Fri Mar 19 11:29:21 2004
@@ -27,7 +27,7 @@
void irlan_check_command_param(struct irlan_cb *self, char *param,
char *value);
-void handle_filter_request(struct irlan_cb *self, struct sk_buff *skb);
+void irlan_filter_request(struct irlan_cb *self, struct sk_buff *skb);
int irlan_print_filter(struct seq_file *seq, int filter_type);
#endif /* IRLAN_FILTER_H */
diff -Nru a/net/irda/irlan/irlan_filter.c b/net/irda/irlan/irlan_filter.c
--- a/net/irda/irlan/irlan_filter.c Fri Mar 19 11:29:21 2004
+++ b/net/irda/irlan/irlan_filter.c Fri Mar 19 11:29:21 2004
@@ -29,12 +29,12 @@
#include <net/irda/irlan_common.h>
/*
- * Function handle_filter_request (self, skb)
+ * Function irlan_filter_request (self, skb)
*
* Handle filter request from client peer device
*
*/
-void handle_filter_request(struct irlan_cb *self, struct sk_buff *skb)
+void irlan_filter_request(struct irlan_cb *self, struct sk_buff *skb)
{
ASSERT(self != NULL, return;);
ASSERT(self->magic == IRLAN_MAGIC, return;);
diff -Nru a/net/irda/irlan/irlan_provider.c b/net/irda/irlan/irlan_provider.c
--- a/net/irda/irlan/irlan_provider.c Fri Mar 19 11:29:21 2004
+++ b/net/irda/irlan/irlan_provider.c Fri Mar 19 11:29:21 2004
@@ -358,7 +358,7 @@
12);
break;
case CMD_FILTER_OPERATION:
- handle_filter_request(self, skb);
+ irlan_filter_request(self, skb);
break;
default:
IRDA_DEBUG(2, "%s(), Unknown command!\n", __FUNCTION__ );
reply other threads:[~2004-04-14 22:21 UTC|newest]
Thread overview: [no followups] expand[flat|nested] mbox.gz Atom feed
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20040414221904.GF5434@bougret.hpl.hp.com \
--to=jt@bougret.hpl.hp.com \
--cc=davem@redhat.com \
--cc=jt@hpl.hp.com \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®