On Wed, Jun 02, 2004 at 09:02:23AM -0400, Patrick J. LoPresti wrote: > Andries Brouwer writes: > > Please, now that this is still unused, fix your names and/or > > your code. Names could be legacy_max_head (etc.) if you want > > to keep the values, or otherwise add 1 to the values. > > Well, the EDD module belongs to Matt Domsch. I only contributed the > "legacy_*" code and names. > > If it is OK with Matt, I agree we should rename legacy_heads to > legacy_max_head and legacy_sectors to legacy_sectors_per_track. I > doubt anybody other than myself is using these yet anyway. Yes, please submit a patch now to Andrew, cc: me and linux-kernel at least. I've confirmed that our internal tools are not using these fields yet. > > Also - people will try to match the 0x7280b80 for int13_dev83 with > > the 120064896 sectors that dmesg or hdparm -g reports for /dev/hdf. > > Life would be easier with values given in decimal, as they are > > everywhere else. > > I used hex for legacy_* because that is what all the other fields > already used. It was not my decision, and I have no opinion either > way. Convince Matt. Whatever, scanf works with either representation. Patrick, if you're changing the above, feel free to submit a second patch to switch these all to %u instead. Thanks, Matt -- Matt Domsch Sr. Software Engineer, Lead Engineer Dell Linux Solutions linux.dell.com & www.dell.com/linux Linux on Dell mailing lists @ http://lists.us.dell.com