mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Randy.Dunlap" <rddunlap@osdl.org>
To: Paul Mundt <lethal@linux-sh.org>
Cc: geert@linux-m68k.org, linux-kernel@vger.kernel.org, akpm@osdl.org
Subject: Re: [PATCH] Kconfig.debug: combine Kconfig debug options
Date: Tue, 27 Jul 2004 13:14:15 -0700	[thread overview]
Message-ID: <20040727131415.51260cca.rddunlap@osdl.org> (raw)
In-Reply-To: <20040727190210.GE20740@linux-sh.org>

On Tue, 27 Jul 2004 15:02:11 -0400 Paul Mundt wrote:

| On Tue, Jul 27, 2004 at 10:47:37AM -0700, Randy.Dunlap wrote:
| > DEBUG_SLAB is not available in cris, h8300, m68knommu, sh, sh64,
| > or v850 AFAICT.  Yes/no ?
| > 
| This can be set for sh/sh64 just fine, it is pretty much generic anyways.
| So placing this in a common Kconfig seems reasonable.

Changed that, thanks.

| > | (didn't check the whole list) Perhaps the first instance of DEBUG_INFO
| > | can depend on !SUPERH64 && !USERMODE only?
| > 
| > It could.  It depends on one's config (or code/patch) philosophy.
| > I was trying to be explicit about which arches support a config option
| > by including each arch in a list ("inclusion").  Or I could exclude
| > certain arches from config options ("exclusion").  The inclusion
| > method seems safer and more readable/maintainable to me, but that's
| > just one opinion.
| > 
| There's no need for the !SUPERH64 dependancy for DEBUG_INFO either, so
| feel free to drop that if that's the way you end up going.

Changed that one also.

Along with 3 changes in response to Geert:
- DEBUG_KERNEL applies to all arch-es;
- DEBUG_SPINLOCK depends only on DEBUG_KERNEL && SMP;
- DEBUG_HIGHMEM depends only on DEBUG_KERNEL && HIGHMEM;

Updated patch (applies to 2.6.8-rc2-bk6) is now available at
  http://developer.osdl.org/rddunlap/kconfig/kconfig-debug-268rc2bk6.patch

(approx. 133 KB)

---

Localize Kconfig debug options into one file (lib/Kconfig.debug)
for easier maintenance and searching.


Summary of changes:

. localizes the following symbols in lib/Kconfig.debug:
    DEBUG_KERNEL, MAGIC_SYSRQ, DEBUG_SLAB, DEBUG_SPINLOCK,
    DEBUG_SPINLOCK_SLEEP, DEBUG_HIGHMEM, DEBUG_BUGVERBOSE,
    DEBUG_INFO
  and FRAME_POINTER for some instances of it (if it's freely
  user-selectable) but not for the cases where it's forced or
  it depends on some other options.
. adds DEBUG_KERNEL requirement to some DEBUG_vars;
. DEBUG_KERNEL applies to all arch-es;
. remove KALLSYMS from S390-specific kernel hacking menu;
  use KALLSYMS in the EMBEDDED menu instead;
. add CRIS and M68KNOMMU symbols for use in lib/Kconfig.debug;
. eliminate duplicate "General setup" labels in sparc64 config;
. whitespace cleanup;
. fixed a few trival typos;


Portions of the original patch were also done by
Bartlomiej Zolnierkiewicz <B.Zolnierkiewicz@elka.pw.edu.pl>

Signed-off-by: Randy Dunlap <rddunlap@osdl.org>
--

  reply	other threads:[~2004-07-27 20:34 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2004-07-24  6:11 Randy.Dunlap
2004-07-27 12:55 ` Geert Uytterhoeven
2004-07-27 17:47   ` Randy.Dunlap
2004-07-27 19:02     ` Paul Mundt
2004-07-27 20:14       ` Randy.Dunlap [this message]
2004-07-27 21:29     ` Geert Uytterhoeven
2004-07-28 16:08       ` Randy.Dunlap

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20040727131415.51260cca.rddunlap@osdl.org \
    --to=rddunlap@osdl.org \
    --cc=akpm@osdl.org \
    --cc=geert@linux-m68k.org \
    --cc=lethal@linux-sh.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®