On Tue, Jul 27, 2004 at 10:47:37AM -0700, Randy.Dunlap wrote: > DEBUG_SLAB is not available in cris, h8300, m68knommu, sh, sh64, > or v850 AFAICT. Yes/no ? > This can be set for sh/sh64 just fine, it is pretty much generic anyways. So placing this in a common Kconfig seems reasonable. > | (didn't check the whole list) Perhaps the first instance of DEBUG_INFO > | can depend on !SUPERH64 && !USERMODE only? > > It could. It depends on one's config (or code/patch) philosophy. > I was trying to be explicit about which arches support a config option > by including each arch in a list ("inclusion"). Or I could exclude > certain arches from config options ("exclusion"). The inclusion > method seems safer and more readable/maintainable to me, but that's > just one opinion. > There's no need for the !SUPERH64 dependancy for DEBUG_INFO either, so feel free to drop that if that's the way you end up going.