hi :) On Tue, Sep 28, 2004 at 01:10:21PM +0100, Paulo Marques wrote: > Of course your way is more robust to future 'netif_carrier_ok' changes > and the compiler should optimize it way anyway since it is an inline > function, so I actually prefer the !! version :) But perhaps those future changes would be interesting for userspace, too? -- Martin Waitz