From: "Jörn Engel" <joern@wohnheim.fh-wedel.de>
To: Geert Uytterhoeven <geert@linux-m68k.org>
Cc: Willy Tarreau <willy@w.ods.org>,
Denis Vlasenko <vda@port.imtp.ilyichevsk.odessa.ua>,
Linux Kernel Development <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] Console: fall back to /dev/null when no console is availlable
Date: Wed, 6 Oct 2004 16:12:31 +0200 [thread overview]
Message-ID: <20041006141231.GA6394@wohnheim.fh-wedel.de> (raw)
In-Reply-To: <Pine.GSO.4.61.0410061548390.20160@waterleaf.sonytel.be>
On Wed, 6 October 2004 15:55:52 +0200, Geert Uytterhoeven wrote:
>
> One problem is that `console' means multiple things:
> 1. The output device for printk() (multiple consoles are allowed, cfr.
> multiple console= kernel parameters and debug-only consoles)
> 2. The tty (both input and output) for /sbin/init (only one instance, cfr.
> the last console= kernel parameter)
Correct. It may be nice have a seperate logic for 1. 'console' is a
good name for 2., so I would keep that. But then again, I don't care
enough to write a patch.
> I suggested to change the logic for 2 not to use the last console= kernel
> parameter if it turns out not to support input (cfr. the return value of struct
> console.device()), but try the other registered struct consoles.
>
> [...]
>
> > Having a non-working console, esp. for debug, is a rather odd design.
> > My approach would be to either explicitly tell the kernel to use the
> > other as default console via "console=/dev/ttyS0" or not have the
> > debug thing in the kernel in the first place. Either way, no patch is
> > needed.
>
> It was not `designed' to be that way. But due to how `the console' (nr. 2 from
> above) works, registration order matters. If people make the mistake (or just
> forget) to say `console=ttyS0', a debug console registered later causes
> problems.
>
> And the reason the debug consoles (read: capturers) use register_console() is
> to avoid code duplication.
Which is fair. So we end up with two devices claiming to be a valid
console, but one of them makes people unhappy. Are you certain that
*everone* wants to have 'ttyS0' as default console and not 'debug'?
Taking the last one registered is basically random. If people care
enough, they should explicitly state things on the command line.
Taking the last with input support (or the last, if none support
input) adds some policy. If people disagree with the kernel policy,
they should explicitly state things...
Policy inside the kernel sounds like a bad idea. People can already
get what they want, if they... Policy will help some people with
similar taste, but people with different taste can "argue" against it
and someone has to play judge - not my cup of tea.
Jörn
--
Premature optimization is the root of all evil.
-- Donald Knuth
next prev parent reply other threads:[~2004-10-06 14:12 UTC|newest]
Thread overview: 45+ messages / expand[flat|nested] mbox.gz Atom feed top
2004-10-05 18:52 Jörn Engel
2004-10-05 20:27 ` Russell King
2004-10-05 21:06 ` Greg KH
2004-10-05 21:13 ` Russell King
2004-10-06 15:00 ` Alan Cox
2004-10-06 17:41 ` Greg KH
2004-10-06 18:01 ` Jörn Engel
2004-10-06 18:18 ` Greg KH
2004-10-06 19:20 ` Jörn Engel
2004-10-06 18:26 ` Chris Wright
2004-10-06 18:16 ` Andries Brouwer
2004-10-06 19:18 ` Alan Cox
2004-10-06 20:54 ` Greg KH
2004-10-06 20:29 ` Alan Cox
2004-10-06 21:45 ` Russell King
2004-10-07 5:51 ` Valdis.Kletnieks
2004-10-08 2:15 ` Herbert Xu
2004-10-06 20:01 ` Russell King
2004-10-05 22:36 ` Andries Brouwer
2004-10-06 6:43 ` Russell King
2004-10-07 14:41 ` Jan-Benedict Glaw
2004-10-05 21:58 ` Denis Vlasenko
2004-10-06 4:34 ` Willy Tarreau
2004-10-06 8:43 ` Geert Uytterhoeven
2004-10-06 12:15 ` Jörn Engel
2004-10-06 13:07 ` Geert Uytterhoeven
2004-10-06 13:33 ` Jörn Engel
2004-10-06 13:55 ` Geert Uytterhoeven
2004-10-06 14:12 ` Jörn Engel [this message]
2004-10-06 14:23 ` Geert Uytterhoeven
2004-10-06 15:28 ` Jörn Engel
2004-10-06 15:36 ` Geert Uytterhoeven
2004-10-06 15:51 ` Jörn Engel
2004-10-05 23:30 ` Andrew Morton
2004-10-06 12:16 ` Jörn Engel
2004-10-06 17:38 ` Greg KH
2004-10-06 18:04 ` Jörn Engel
2004-10-06 18:19 ` Greg KH
2004-10-06 19:23 ` Jörn Engel
2004-10-06 21:22 ` Thayne Harbaugh
2004-10-07 8:18 ` Geert Uytterhoeven
2004-10-07 9:07 ` Russell King
2004-10-07 9:46 ` Geert Uytterhoeven
2004-10-06 18:37 ` Gianni Tedesco
2004-10-06 19:08 ` Jörn Engel
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20041006141231.GA6394@wohnheim.fh-wedel.de \
--to=joern@wohnheim.fh-wedel.de \
--cc=geert@linux-m68k.org \
--cc=linux-kernel@vger.kernel.org \
--cc=vda@port.imtp.ilyichevsk.odessa.ua \
--cc=willy@w.ods.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®