From: Herbert Poetzl <herbert@13thfloor.at>
To: "Richard B. Johnson" <root@chaos.analogic.com>
Cc: Sam Ravnborg <sam@ravnborg.org>,
Linux kernel <linux-kernel@vger.kernel.org>
Subject: Re: Module compilation
Date: Fri, 22 Oct 2004 04:54:27 +0200 [thread overview]
Message-ID: <20041022025427.GA3440@mail.13thfloor.at> (raw)
In-Reply-To: <Pine.LNX.4.61.0410211415560.14971@chaos.analogic.com>
On Thu, Oct 21, 2004 at 02:21:25PM -0400, Richard B. Johnson wrote:
> On Thu, 21 Oct 2004, Sam Ravnborg wrote:
>
> >On Wed, Oct 20, 2004 at 10:36:00AM -0400, Richard B. Johnson wrote>
> >>...but it's not CFLAGS that needs to be modified, it's
> >>a named variable that doesn't exist yet, perhaps "USERDEF",
> >>or "DEFINES".
> >
> >Reading the above I cannot what amkes you say that EXTRA_CFLAGS
> >or CFLAGS_module.o cannot be used?
> >Is it the name you do not like or is it some fnctionality
> >you are missing?
> >
>
> The name is wrong! There are zillions of ways to obtain the
> functionality. Currently we need to piggy-back definitions
> onto compiler flags.
>
> Compiler flags are things like "-Wall" and "-O2", that tell
> the compiler what to do. We need a name to use for definitions,
> "-Dxxx", that #define constants (dynamically at compile-time)
> in the code. Right now, -DMODULE and -D__KERNEL__ are piggybacked
> onto CFLAGS. There really should be a variable called something
> else like DEFINES and it should be exported.
hmm, the man page for gcc states that
-Dmacro is a preprocessor option, where
-Wall is a compiler option, and
-O2 is an optimization option
but, all of those are options to the cpp/gcc
toolchain (or gcc compiler if you like), so
it sounds natural to me to put it there ...
(i.e. CFLAGS*)
best,
Herbert
> >>I see that the normal "defines" is a constant
> >>called "CHECKFLAGS", so this isn't appropriate for user
> >>modification.
> >CHECKFLAGS is only used when you use "make C=1" - to pass options
> >to sparse.
> >
> > Sam
> >
>
> Cheers,
> Dick Johnson
> Penguin : Linux version 2.6.9 on an i686 machine (5537.79 GrumpyMips).
> 98.36% of all statistics are fiction.
> -
> To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at http://vger.kernel.org/majordomo-info.html
> Please read the FAQ at http://www.tux.org/lkml/
prev parent reply other threads:[~2004-10-22 3:26 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2004-10-20 14:36 Richard B. Johnson
2004-10-20 14:49 ` David Woodhouse
2004-10-20 15:01 ` Richard B. Johnson
2004-10-20 14:59 ` Ian Campbell
2004-10-20 15:06 ` Richard B. Johnson
2004-10-21 20:15 ` Sam Ravnborg
2004-10-21 18:21 ` Richard B. Johnson
2004-10-22 2:54 ` Herbert Poetzl [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20041022025427.GA3440@mail.13thfloor.at \
--to=herbert@13thfloor.at \
--cc=linux-kernel@vger.kernel.org \
--cc=root@chaos.analogic.com \
--cc=sam@ravnborg.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®