mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Dale Farnsworth" <dale@farnsworth.org>
To: Christoph Hellwig <hch@infradead.org>, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 3/6] mv643xx_eth: fix hw checksum generation on transmit
Date: Wed, 15 Dec 2004 11:12:58 -0700	[thread overview]
Message-ID: <20041215181258.GB17904@xyzzy> (raw)
In-Reply-To: <20041214231555.GB11617@infradead.org>

On Tue, Dec 14, 2004 at 11:15:55PM +0000, Christoph Hellwig wrote:
> > +			dev_kfree_skb_irq((struct sk_buff *)
> > +                                                  pkt_info.return_info);
> 
> pkt_info.return_info already is a pointer to struct sk_buff

Yep.  This line was moved, but not changed by my patch.  I'll remove the
cast.

> > +			/* CPU already calculated pseudo header checksum. */
> > +			if (skb->nh.iph->protocol == IPPROTO_UDP) {
> > +				pkt_info.cmd_sts |= ETH_UDP_FRAME;
> > +				pkt_info.l4i_chk = skb->h.uh->check;
> > +			}
> > +			else if (skb->nh.iph->protocol == IPPROTO_TCP)
> > +				pkt_info.l4i_chk = skb->h.th->check;
> > +			else {
> 
> 			} else if (skb->nh.iph->protocol == IPPROTO_TCP) {
> 				pkt_info.l4i_chk = skb->h.th->check;
> 			} else {
> 
> > +	pkt_info.buf_ptr = pci_map_single(0, skb->data, skb->len,
> > +							PCI_DMA_TODEVICE);
> 
> s/0/NULL/ to avoid sparse warnings

Another line that was moved but not changed.  In patch 4/6 I changed it
to dma_map_single(NULL, ...

> > +	/*
> > +	 * The hardware requires that each buffer that is <= 8 bytes
> > +	 * in length must be aligned on an 8 byte boundary.
> > +	 */
> > +        if (p_pkt_info->byte_cnt <= 8 && p_pkt_info->buf_ptr & 0x7) {
> 
> please use tabs, not spaces for indentation.

Again, I didn't change the indentation on this line.  The driver is
replete with whitespace problems.  I don't want to address them now,
but as soon as it's confirmed that these patches are "in the queue",
I'll submit several cosmetic patches:  white space cleanup, rename
from 64340 to 643xx, rename MV_READ/MV_WRITE to mv_read/mv_write,
and a few localized code simplifications.

> >  #ifdef MV64340_CHECKSUM_OFFLOAD_TX
> > -        int tx_first_desc;
> > +        int tx_busy_desc = mp->tx_first_desc_q;
> 
> Again.

Thanks,
-Dale

  reply	other threads:[~2004-12-15 18:13 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2004-12-13 22:09 [PATCH] mv643xx_eth support for platform device interface + more Dale Farnsworth
2004-12-13 22:12 ` [PATCH 1/6] mv643xx_eth: remove redundant/useless code Dale Farnsworth
2004-12-13 22:14 ` [PATCH 2/6] mv643xx_eth: replace fixed-count spin delays Dale Farnsworth
2004-12-14 23:11   ` Christoph Hellwig
2004-12-15 18:03     ` Dale Farnsworth
2004-12-13 22:15 ` [PATCH 3/6] mv643xx_eth: fix hw checksum generation on transmit Dale Farnsworth
     [not found]   ` <41BE1744.4060502@penguin.mvista>
2004-12-14  5:03     ` Dale Farnsworth
2004-12-14 23:15   ` Christoph Hellwig
2004-12-15 18:12     ` Dale Farnsworth [this message]
2004-12-13 22:18 ` [PATCH 4/6] mv643xx_eth: Convert from pci_map_* to dma_map_* interface Dale Farnsworth
2004-12-13 22:19 ` [PATCH 5/6] mv643xx_eth: Add support for platform device interface Dale Farnsworth
2004-12-14 23:19   ` Christoph Hellwig
2004-12-15 18:32     ` Dale Farnsworth
2004-12-13 22:20 ` [PATCH 6/6] mv643xx_eth: add configurable parameters via " Dale Farnsworth
2004-12-14 22:51 ` [PATCH 7/6] mv643xx_eth: Remove use of MV_SET_REG_BITS macro Dale Farnsworth
2004-12-14 22:56   ` Russell King
2004-12-15 19:02 ` [PATCH] mv643xx_eth support for platform device interface + more Dale Farnsworth
2004-12-15 19:18   ` [PATCH 8/6] mv643xx_eth: address style issues raised by Christoph Hellwig Dale Farnsworth

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20041215181258.GB17904@xyzzy \
    --to=dale@farnsworth.org \
    --cc=hch@infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®