mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Chris Wedgwood <cw@f00f.org>
To: Matt Mackall <mpm@selenic.com>
Cc: Andrew Morton <akpm@osdl.org>, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 2/8] lib/sort: Replace qsort in XFS
Date: Tue, 1 Feb 2005 14:29:15 -0800	[thread overview]
Message-ID: <20050201222915.GA9285@taniwha.stupidest.org> (raw)
In-Reply-To: <7.416337461@selenic.com> <6.416337461@selenic.com> <4.416337461@selenic.com> <3.416337461@selenic.com>

On Mon, Jan 31, 2005 at 01:34:59AM -0600, Matt Mackall wrote:

> +#define qsort xfs_sort
> +static inline void xfs_sort(void *a, size_t n, size_t s,
> +			int (*cmp)(const void *,const void *))
> +{
> +	sort(a, n, s, cmp, 0);
> +}
> +

why not just:

#define qsort(a, n, s, cmp)	sort(a, n, s, cmp, NULL)



On Mon, Jan 31, 2005 at 01:35:00AM -0600, Matt Mackall wrote:

> Switch NFS ACLs to lib/sort

> +	sort(acl->a_entries, acl->a_count, sizeof(struct posix_acl_entry),
> +	     cmp_acl_entry, 0);

There was a thread about stlye and I though the concensurs for null
pointers weas to use NULL and not 0?



On Mon, Jan 31, 2005 at 01:35:00AM -0600, Matt Mackall wrote:

> Eep. cpuset uses bubble sort on a data set that's potentially O(#
> processes). Switch to lib/sort.

> +	sort(pidarray, npids, sizeof(pid_t), cmppid, 0);

and there?



On Mon, Jan 31, 2005 at 01:35:00AM -0600, Matt Mackall wrote:

> Replace exception table insertion sort with lib/sort

> +	sort(start, finish - start, sizeof(struct exception_table_entry),
> +	     cmp_ex, 0);

and there?


  parent reply	other threads:[~2005-02-01 22:33 UTC|newest]

Thread overview: 36+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2005-01-31  7:34 [PATCH 0/8] lib/sort: Add generic sort to lib/ Matt Mackall
2005-01-31  7:34 ` [PATCH 1/8] lib/sort: Heapsort implementation of sort() Matt Mackall
2005-01-31  7:34   ` [PATCH 2/8] lib/sort: Replace qsort in XFS Matt Mackall
2005-01-31  7:35     ` [PATCH 3/8] lib/sort: Replace qsort in NFS ACL code Matt Mackall
2005-01-31  7:35       ` [PATCH 4/8] lib/sort: Kill qsort() Matt Mackall
2005-01-31  7:35         ` [PATCH 5/8] lib/sort: Replace open-coded O(pids**2) bubblesort in cpusets Matt Mackall
2005-01-31  7:35           ` [PATCH 6/8] lib/sort: Replace insertion sort in exception tables Matt Mackall
2005-01-31  7:35             ` [PATCH 7/8] lib/sort: Replace insertion sort in IA64 " Matt Mackall
2005-01-31  7:35               ` [PATCH 8/8] lib/sort: Use generic sort on x86_64 Matt Mackall
2005-01-31 12:02           ` [PATCH 5/8] lib/sort: Replace open-coded O(pids**2) bubblesort in cpusets Paul Jackson
2005-01-31 17:16   ` [PATCH 1/8] lib/sort: Heapsort implementation of sort() Andreas Gruenbacher
2005-01-31 17:30     ` Paulo Marques
2005-02-01 17:54       ` Andreas Gruenbacher
2005-02-01 18:11         ` linux-os
2005-02-01 19:04           ` linux-os
2005-02-01 19:47           ` Andreas Gruenbacher
2005-01-31 19:30     ` Matt Mackall
2005-02-01 17:50       ` Andreas Gruenbacher
2005-02-02  1:00         ` Horst von Brand
2005-02-02 10:50     ` Herbert Xu
2005-02-02 11:14       ` Andreas Gruenbacher
2005-02-03 23:19         ` Junio C Hamano
2005-02-01  2:10   ` Horst von Brand
2005-02-01 22:29   ` Chris Wedgwood [this message]
2005-02-01 22:22     ` [PATCH 2/8] lib/sort: Replace qsort in XFS Randy.Dunlap
2005-02-02  4:31       ` Zan Lynx
2005-02-02 10:48         ` Herbert Xu
2005-02-01 22:48     ` Matt Mackall
2005-02-27 13:17   ` [PATCH 1/8] lib/sort: Heapsort implementation of sort() Andreas Gruenbacher
2005-02-27 21:25     ` Matt Mackall
2005-02-27 21:53       ` Andreas Gruenbacher
2005-02-27 22:10         ` Andreas Gruenbacher
2005-03-01 13:23       ` Andreas Gruenbacher
2005-03-01 19:06       ` Christophe Saout
2005-03-01 20:12         ` Matt Mackall
2005-03-01 21:47           ` Andrew Morton

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20050201222915.GA9285@taniwha.stupidest.org \
    --to=cw@f00f.org \
    --cc=akpm@osdl.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mpm@selenic.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®