From: Nick Wilson <njw@osdl.org>
To: linux-kernel@vger.kernel.org, akpm@osdl.org, rddunlap@osdl.org
Subject: [PATCH 0/6] add generic round_up_pow2() macro
Date: Thu, 7 Apr 2005 17:44:28 -0700 [thread overview]
Message-ID: <20050408004428.GA4260@njw.pdx.osdl.net> (raw)
Randy.Dunlap wrote:
> >+#define ALIGN_DATA_SIZE(size) ((size + PAGE_SIZE - 1) & ~(PAGE_SIZE - 1))
>
> ISTM that we need a generic round_up() function or macro in kernel.h.
>
> a.out.h, reiserfs_fs.h, and ufs_fs.h all have their own round-up
> macros.
I've found many more places in the kernel that use their own functions for
doing this. These patches are the beginning of an attempt to clean these
up.
The first patch adds a generic round_up_pow2() macro to kernel.h. The
remaining patches modify a few files to make use of the new macro.
Comments welcome.
Thanks,
Nick
next reply other threads:[~2005-04-08 0:43 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2005-04-08 0:44 Nick Wilson [this message]
2005-04-08 0:48 ` [PATCH 1/6] include/linux/kernel.h: use " Nick Wilson
2005-04-08 0:49 ` [PATCH 2/6] " Nick Wilson
2005-04-08 0:50 ` [PATCH 3/6] include/linux/a.out.h: " Nick Wilson
2005-04-08 0:50 ` [PATCH 0/6] add " Andrew Morton
2005-04-08 9:57 ` P
2005-04-08 10:32 ` P
2005-04-08 18:50 ` [PATCH] Use ALIGN to remove duplicate code Nick Wilson
2005-04-08 0:50 ` [PATCH 4/6] kernel/resource.c: use generic round_up_pow2() macro Nick Wilson
2005-04-08 0:51 ` [PATCH 5/6] lib/bitmap.c: " Nick Wilson
2005-04-08 0:52 ` [PATCH 6/6] mm/bootmem.c: " Nick Wilson
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20050408004428.GA4260@njw.pdx.osdl.net \
--to=njw@osdl.org \
--cc=akpm@osdl.org \
--cc=linux-kernel@vger.kernel.org \
--cc=rddunlap@osdl.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®