mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: randy_dunlap <rdunlap@xenotime.net>
To: "McMullan, Jason" <jason.mcmullan@timesys.com>
Cc: PPC_LINUX@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 2.6.11.7] ATA Over Ethernet Root
Date: Fri, 13 May 2005 10:48:37 -0700	[thread overview]
Message-ID: <20050513104837.31fd20e6.rdunlap@xenotime.net> (raw)
In-Reply-To: <1116004796.9050.83.camel@jmcmullan.timesys>

On Fri, 13 May 2005 13:19:55 -0400 McMullan, Jason wrote:

| This patch allows you to use ATA Over Ethernet as your root device,
| with 'root=/dev/etherd/eX.Y/disc'
| 
| Limited testing, just for ya'lls review.
or                          y'alls


Please make patches against 2.6.12-rcX, not against 2.6.11.z.
(probably doesn't matter in this case)


+struct aoedev *
+aoedev_bymajor_minor(ulong major, ulong minor)
+{

Kernel preferred style is not to split the function definition line.


+#ifdef CONFIG_ATA_OVER_ETH_ROOT
+#include <linux/delay.h>
+#include <linux/rtnetlink.h>
+#include <linux/netdevice.h>
+#include <net/sock.h>
+#endif

Lose the ifdef/endif.  Don't make #includes conditional.

+printk("Bring up loopback...\n");
+	if (dev_change_flags(&loopback_dev, loopback_dev.flags | IFF_UP) < 0)
+		printk(KERN_ERR "AOE Root: Failed to open %s\n", loopback_dev.name);
+
+	/* Setup all network devices */
+	for (dev = dev_base; dev ; dev = dev->next) {
+		if (dev == &loopback_dev)
+			continue;
+printk("Bring up %s...\n",dev->name);

Did you mean to leave these printk()s here?
I think not, but if so, they need a KERN_ level, like KERN_INFO.


It would help readability if you would add some spaces around
'=', after commas, etc., in places like these:

+	for (d=devlist; d; d=d->next)
and
+	} while (!aoedev_bymajor_minor(CONFIG_ATA_OVER_ETH_ROOT_SHELF,CONFIG_ATA_OVER_ETH_ROOT_SLOT));
and
+	aoe_root(CONFIG_ATA_OVER_ETH_ROOT_SHELF,CONFIG_ATA_OVER_ETH_ROOT_SLOT);


Thanks.

---
~Randy

      reply	other threads:[~2005-05-13 17:48 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2005-05-13 17:19 McMullan, Jason
2005-05-13 17:48 ` randy_dunlap [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20050513104837.31fd20e6.rdunlap@xenotime.net \
    --to=rdunlap@xenotime.net \
    --cc=PPC_LINUX@vger.kernel.org \
    --cc=jason.mcmullan@timesys.com \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®