mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Christoph Hellwig <hch@infradead.org>
To: Ram <linuxram@us.ibm.com>
Cc: Christoph Hellwig <hch@infradead.org>,
	Jeff Mahoney <jeffm@suse.com>, Andrew Morton <akpm@osdl.org>,
	Linus Torvalds <torvalds@osdl.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] vfs: namei operations should pass nameidata when available
Date: Fri, 10 Jun 2005 21:09:09 +0100	[thread overview]
Message-ID: <20050610200909.GA13315@infradead.org> (raw)
In-Reply-To: <1118430311.4227.10.camel@localhost>

On Fri, Jun 10, 2005 at 12:05:11PM -0700, Ram wrote:
> On Mon, 2005-03-28 at 12:17, Christoph Hellwig wrote:
> > > +	dentry = __lookup_hash(&nd->last, nd->dentry, nd);
> > 
> > Please add a tiny wrapper lookup_hash_nd(struct nameidata *nd)
> > that expands to the above instead of opencoding it everywhere.
> > 
> > Or just call it lookup_hash() after you removed the original version..
> 
> Jeff,
> 
>    I have incorporated the Christophs' comments. 
>    lookup_hash() now takes a third
>    nameidata argument. I touch tested it. If you like the patch can
>    your forward it to Andrew.

No, please wait.  I have a patch series pending for post 2.6.12 that
revamps this code area little, lookup_hash will only take a nameidata *
after that.


      reply	other threads:[~2005-06-10 20:09 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2005-03-28 20:06 Jeff Mahoney
2005-03-28 20:17 ` Christoph Hellwig
2005-06-10 19:05   ` Ram
2005-06-10 20:09     ` Christoph Hellwig [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20050610200909.GA13315@infradead.org \
    --to=hch@infradead.org \
    --cc=akpm@osdl.org \
    --cc=jeffm@suse.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linuxram@us.ibm.com \
    --cc=torvalds@osdl.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®