hoi :) On Mon, Jun 20, 2005 at 01:38:00PM -0700, Andrew Morton wrote: > Yes, it is cleaner that way. Well, I don't think so... > The old trick to make the error-handling code out-of-line shouldn't be > needed nowadays - IS_ERR uses unlikely(), which is supposed to handle that > stuff. IMHO out-of-line error handling improves readability because you have a clear boundary between real functionality and error handling. If both are mixed up you have to look longer at the code to understand the control-flow. -- Martin Waitz