On Fri, 5 Aug 2005 11:39 am, Con Kolivas wrote: > On Fri, 5 Aug 2005 10:53 am, Nick Piggin wrote: > > All else being equal, it is much better if you unlock in the > > same function that takes the lock. For readability. > > > > It looks like you should be able to leave all the flow control > > and locking the same, and use update_monotonic_base() to > > do the actual update? > > Good advice, thanks. Will respin. Like this I assume you meant? Cheers, Con ---