From: Andrew Morton <akpm@osdl.org>
To: Dmitry Torokhov <dtor_core@ameritech.net>
Cc: linux-kernel@vger.kernel.org, penberg@cs.helsinki.fi,
jirislaby@gmail.com, lion.vollnhals@web.de
Subject: Re: [PATCH] use kzalloc instead of malloc+memset
Date: Mon, 12 Sep 2005 23:42:00 -0700 [thread overview]
Message-ID: <20050912234200.10b2abe7.akpm@osdl.org> (raw)
In-Reply-To: <200509130033.11109.dtor_core@ameritech.net>
Dmitry Torokhov <dtor_core@ameritech.net> wrote:
>
> On Monday 12 September 2005 23:43, Pekka Enberg wrote:
> > On 9/13/05, Jiri Slaby <jirislaby@gmail.com> wrote:
> > > >- cls = kmalloc(sizeof(struct class), GFP_KERNEL);
> > > >+ cls = kzalloc(sizeof(struct class), GFP_KERNEL);
> > > >
> > > >
> > > maybe, the better way is to write `*cls' instead of `struct class',
> > > better for further changes
> >
> > Please note that some maintainers don't like it. I at least could not
> > sneak in patches like these to drivers/usb/ because I had changed
> > sizeof.
> >
>
> And given the fact that Greg maintains driver core it probably won't be
> accepted here either :)
>
> FWIW I also prefer spelling out the structure I am allocating.
>
It hurts readability. Quick question: is this code correct?
dev = kmalloc(sizeof(struct net_device), GFP_KERNEL);
you don't know. You have to go hunting down the declaration of `dev' to
find out.
next prev parent reply other threads:[~2005-09-13 6:42 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2005-09-12 22:10 Lion Vollnhals
2005-09-12 22:47 ` Lion Vollnhals
2005-09-13 5:41 ` Denis Vlasenko
2005-09-13 11:27 ` Jiri Slaby
2005-09-12 22:58 ` Jiri Slaby
2005-09-13 4:43 ` Pekka Enberg
2005-09-13 5:33 ` Dmitry Torokhov
2005-09-13 6:42 ` Andrew Morton [this message]
2005-09-13 7:02 ` Pekka J Enberg
2005-09-13 7:42 ` Nikita Danilov
2005-09-13 16:31 ` Pekka Enberg
2005-09-14 5:02 ` Denis Vlasenko
2005-09-14 9:58 ` Nikita Danilov
2005-09-13 23:28 ` Paul Jackson
2005-09-14 9:33 ` Bernd Petrovitsch
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20050912234200.10b2abe7.akpm@osdl.org \
--to=akpm@osdl.org \
--cc=dtor_core@ameritech.net \
--cc=jirislaby@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=lion.vollnhals@web.de \
--cc=penberg@cs.helsinki.fi \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®