mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Andrew Morton <akpm@osdl.org>
To: Hugh Dickins <hugh@veritas.com>
Cc: dev@sw.ru, torvalds@osdl.org, linux-kernel@vger.kernel.org, xemul@sw.ru
Subject: Re: [PATCH] error path in setup_arg_pages() misses vm_unacct_memory()
Date: Tue, 13 Sep 2005 11:37:03 -0700	[thread overview]
Message-ID: <20050913113703.53d53d6a.akpm@osdl.org> (raw)
In-Reply-To: <Pine.LNX.4.61.0509131220540.7040@goblin.wat.veritas.com>

Hugh Dickins <hugh@veritas.com> wrote:
>
> On Tue, 13 Sep 2005, Andrew Morton wrote:
> > Kirill Korotaev <dev@sw.ru> wrote:
> > >
> > > maybe it is worth moving vm_acct_memory() out of 
> > >  security_vm_enough_memory()?
> > 
> > I think that would be saner, yes.  That means that the callers would call
> > vm_acct_memory() after security_enough_memory(), if that succeeded.
> 
> I don't like that at all.  The implementation of its tests is necessarily
> imprecise, but nonetheless, we do prefer primitives which atomically test
> and reserve.  We're not moving from request_region to check_region, are we?

I don't think that it's any racier to move the allocation to after the
check than to have it before the check.  If we're worried, take mmap_sem -
most place already do that, but not all.

> But change the naming by all means, it was never good,
> and grew worse when "security_" got stuck on the front.

Yes, renaming it to something like alloc_vm_space() would suit.

  reply	other threads:[~2005-09-13 18:38 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2005-09-12 16:49 Kirill Korotaev
2005-09-12 20:23 ` Andrew Morton
2005-09-13  8:21   ` Kirill Korotaev
2005-09-13  8:40     ` Andrew Morton
2005-09-13 11:30       ` Hugh Dickins
2005-09-13 18:37         ` Andrew Morton [this message]
2005-09-13 19:10           ` Hugh Dickins
2005-09-13 11:58       ` Alan Cox
2005-09-13 11:20   ` Hugh Dickins
2005-09-13 12:13     ` Kirill Korotaev
2005-09-14  5:13     ` Hugh Dickins
2005-09-14  8:41       ` Kirill Korotaev
2005-09-14  9:14         ` Hugh Dickins

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20050913113703.53d53d6a.akpm@osdl.org \
    --to=akpm@osdl.org \
    --cc=dev@sw.ru \
    --cc=hugh@veritas.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=torvalds@osdl.org \
    --cc=xemul@sw.ru \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®