mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Rafael J. Wysocki" <rjw@sisk.pl>
To: Pavel Machek <pavel@ucw.cz>
Cc: Andrew Morton <akpm@osdl.org>,
	kernel list <linux-kernel@vger.kernel.org>
Subject: Re: [swsusp] separate snapshot functionality to separate file
Date: Mon, 3 Oct 2005 23:39:07 +0200	[thread overview]
Message-ID: <200510032339.08217.rjw@sisk.pl> (raw)
In-Reply-To: <20051002231332.GA2769@elf.ucw.cz>

Hi,

On Monday, 3 of October 2005 01:13, Pavel Machek wrote:
> Split swsusp.c into swsusp.c and snapshot.c. Snapshot only cares
> provides system snapshot/restore functionality, while swsusp.c will
> provide disk i/o. It should enable untangling of the code in future;
> swsusp.c parts can mostly be done in userspace.
> 
> No code changes.

I think that the functions:

read_suspend_image()
read_pagedir()
swsusp_pagedir_relocate() (BTW, why there's "swsusp_"?)
check_pagedir() (BTW, misleading name)
data_read()
eat_page()
get_usable_page()
free_eaten_memory()

should be moved to snapshot.c as well, because they are in fact
symmetrical to what's there (they perform the reverse of creating
the snapshot and use analogous data structures).  IMO the code
change required would not be so drammatic and all of the functions
that _operate_ on the snapshot would be in the same file.

Greetings,
Rafael

  reply	other threads:[~2005-10-03 21:38 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2005-10-02 23:13 Pavel Machek
2005-10-03 21:39 ` Rafael J. Wysocki [this message]
2005-10-03 23:17   ` Pavel Machek
2005-10-04 15:11     ` Rafael J. Wysocki
2005-10-04 20:53       ` Pavel Machek
2005-10-04 22:34         ` Nigel Cunningham
2005-10-05  8:41           ` Pavel Machek
2005-10-05 21:21             ` Lorenzo Colitti
2005-10-05 22:21               ` Nigel Cunningham
2005-10-05 22:44               ` Pavel Machek
2005-10-05 22:54                 ` Lorenzo Colitti
2005-10-05 22:57                   ` Pavel Machek
2005-10-05 23:00                     ` Pavel Machek
2005-10-05 23:18                       ` Lorenzo Colitti
2005-10-06 10:10                         ` Alon Bar-Lev
2005-10-06  8:20                           ` Pavel Machek
2005-10-09 23:41                             ` Nigel Cunningham
2005-10-04 22:47         ` Rafael J. Wysocki
2005-10-05  0:06           ` Pavel Machek
2005-10-05  8:20             ` Rafael J. Wysocki
2005-10-05  8:33               ` Pavel Machek
2005-10-06  8:23                 ` Rafael J. Wysocki
2005-10-06 10:42                   ` Pavel Machek
2005-10-06 13:29                     ` Rafael J. Wysocki

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=200510032339.08217.rjw@sisk.pl \
    --to=rjw@sisk.pl \
    --cc=akpm@osdl.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pavel@ucw.cz \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®