From: Vojtech Pavlik <vojtech@suse.cz>
To: Kay Sievers <kay.sievers@vrfy.org>
Cc: dtor_core@ameritech.net, Greg KH <gregkh@suse.de>,
Hannes Reinecke <hare@suse.de>,
Patrick Mochel <mochel@digitalimplant.org>,
airlied@linux.ie, linux-kernel@vger.kernel.org,
Adam Belay <ambx1@neo.rr.com>
Subject: Re: [patch 0/8] Nesting class_device patches that actually work
Date: Mon, 17 Oct 2005 12:02:23 +0200 [thread overview]
Message-ID: <20051017100223.GB10522@ucw.cz> (raw)
In-Reply-To: <20051014121423.GA21209@vrfy.org>
On Fri, Oct 14, 2005 at 02:14:23PM +0200, Kay Sievers wrote:
> Sorry, my previous drawing wasn't correct for the input devices.
>
> Here is a new picture of the:
> - all classes are unique and flat and will stay the same,
> even when the hierarchy of the devices changes
> - all hierarchy is _only_ in /sys/devices
> - virtual and physical devices are both in /sys/devices
> proposal.
I like the layout.
I'm not completely sure whether mouse0 and event0 are the same class,
because they have different APIs and protocols. And I believe that class
is exactly that - a collection of devices where you can use the same API
to access them. A possibility would be to do it like this:
> /sys
> |-- class
> | |-- mouse
> | | |-- mice -> ../../devices/mice
> | | |-- mouse0 -> ../../devices/platform/i8042/serio0/input0/mouse0
> | |---event
> | | `-- event0 -> ../../devices/platform/i8042/serio0/input0/event0
> | |-- input
> | | `-- input0 -> ../../devices/platform/i8042/serio0/input0
> | `-- tty
> | `-- console -> ../../devices/console
It might be too much work to create a new class in each of the
handlers, it'd be similar to harddrives and partititions having
different classes.
> /sys
> |-- class
> | |-- input
> | | |-- mice -> ../../devices/mice
> | | |-- mouse0 -> ../../devices/platform/i8042/serio0/input0/mouse0
> | | `-- event0 -> ../../devices/platform/i8042/serio0/input0/event0
> | |-- input_device
> | | `-- input0 -> ../../devices/platform/i8042/serio0/input0
> |
> |-- devices
> | |-- platform
> | | `-- i8042
> | | `-- serio0
> | | `-- input0
> | | |-- event0
> | | | `-- dev
> | | |-- mouse0
> | | | `-- dev
> | | |-- bind_mode
> | | |-- description
> | | |-- id
> | | | |-- extra
> | | | |-- id
> | | | |-- proto
> | | | `-- type
> | | |-- modalias
> | | |-- protocol
> | | |-- rate
> | | |-- resetafter
> | | `-- resolution
> | |-- mice
> | | `-- dev
Having 'mice' at top level is not very nice. It's a logical consequence
of the system, and as such probably correct, though.
--
Vojtech Pavlik
SuSE Labs, SuSE CR
next prev parent reply other threads:[~2005-10-17 10:02 UTC|newest]
Thread overview: 44+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <20051013014147.235668000@echidna.kroah.org>
2005-10-13 2:08 ` Greg KH
2005-10-13 2:10 ` Greg KH
2005-10-13 23:38 ` Kay Sievers
2005-10-13 2:10 ` [patch 1/8] Driver Core: add the ability for class_device structures to be nested Greg KH
2005-10-13 2:10 ` [patch 2/8] Driver Core: fix up all callers of class_device_create() Greg KH
2005-10-13 2:10 ` [patch 3/8] Driver Core: document struct class_device properly Greg KH
2005-10-13 2:10 ` [patch 4/8] input: register the input class device sooner Greg KH
2005-10-13 2:10 ` [patch 5/8] input: export input_dev_class so that input drivers can use it Greg KH
2005-10-13 2:10 ` [patch 6/8] input: move the input class devices under their new input_dev devices Greg KH
2005-10-13 2:11 ` [patch 7/8] input: remove the input_class structure, as it is unused Greg KH
2005-10-13 2:11 ` [patch 8/8] input: rename input_dev_class to input_class to be correct Greg KH
2005-10-13 6:38 ` [patch 0/8] Nesting class_device patches that actually work Vojtech Pavlik
2005-10-13 21:21 ` Dmitry Torokhov
2005-10-13 10:58 ` Kay Sievers
2005-10-13 21:35 ` Dmitry Torokhov
2005-10-13 23:37 ` Hannes Reinecke
2005-10-14 8:45 ` Kay Sievers
2005-10-14 12:14 ` Kay Sievers
2005-10-14 12:49 ` linux-os (Dick Johnson)
2005-10-14 13:49 ` Kay Sievers
2005-10-17 10:02 ` Vojtech Pavlik [this message]
2005-10-18 5:13 ` Dmitry Torokhov
2005-10-14 17:02 ` Dmitry Torokhov
2005-10-15 15:08 ` Kay Sievers
2005-10-17 5:41 ` Dmitry Torokhov
2005-10-17 21:44 ` Greg KH
2005-10-17 21:54 ` Dmitry Torokhov
2005-10-17 23:26 ` Adam Belay
2005-10-18 0:03 ` Kay Sievers
2005-10-17 23:24 ` Adam Belay
2005-10-17 23:44 ` Kay Sievers
2005-10-18 5:26 ` Greg KH
2005-10-18 7:18 ` Adam Belay
2005-10-18 7:54 ` Greg KH
2005-10-18 8:34 ` Vojtech Pavlik
2005-10-18 15:08 ` Kay Sievers
2005-10-18 15:41 ` Dmitry Torokhov
2005-10-18 6:04 ` Greg KH
2005-10-18 7:05 ` Greg KH
2005-10-18 7:35 ` Greg KH
2005-10-17 9:26 ` Vojtech Pavlik
2005-12-01 18:59 ` Patrick Mochel
2005-10-14 9:52 ` Christoph Hellwig
2005-10-14 16:36 ` Dmitry Torokhov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20051017100223.GB10522@ucw.cz \
--to=vojtech@suse.cz \
--cc=airlied@linux.ie \
--cc=ambx1@neo.rr.com \
--cc=dtor_core@ameritech.net \
--cc=gregkh@suse.de \
--cc=hare@suse.de \
--cc=kay.sievers@vrfy.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mochel@digitalimplant.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®