From: Andrew Morton <akpm@osdl.org>
To: Pekka Enberg <penberg@cs.helsinki.fi>
Cc: linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/3] mm: rename kmem_cache_s to kmem_cache
Date: Mon, 31 Oct 2005 01:15:01 -0800 [thread overview]
Message-ID: <20051031011501.3caeba18.akpm@osdl.org> (raw)
In-Reply-To: <ip33z2.vtcnft.4nw33ugftrecz8r4nb1via846.beaver@cs.helsinki.fi>
Pekka Enberg <penberg@cs.helsinki.fi> wrote:
>
> This patch renames struct kmem_cache_s to kmem_cache so we can start using it
> instead of kmem_cache_t typedef.
Well I stared at these diffs for a long time. They don't really add a lot
of value to the kernel and they do risk breaking other people's patches.
Generally they have a high hassle/value ratio.
I could merge them up and see how it goes, but given that there are many
more kmem_cache_t->struct kmem_cache conversions to go, and that I hit
seven rejects in mm/slab.c, I think I'll duck the patches, sorry.
> -void filp_ctor(void * objp, struct kmem_cache_s *cachep, unsigned long cflags)
> +void filp_ctor(void * objp, struct kmem_cache *cachep, unsigned long cflags)
See the inconsistent coding style there? This would have been a zero-cost
opportunity to fix that up. (Nuke the space after the asterisk).
next prev parent reply other threads:[~2005-10-31 8:15 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2005-10-28 19:11 Pekka Enberg
2005-10-28 19:11 ` [PATCH 2/3] mm: use struct kmem_cache instead of kmem_cache_t Pekka Enberg
2005-10-28 19:11 ` [PATCH 3/3] fs: " Pekka Enberg
2005-10-31 9:15 ` Andrew Morton [this message]
2005-10-31 8:29 ` [PATCH 1/3] mm: rename kmem_cache_s to kmem_cache Pekka J Enberg
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20051031011501.3caeba18.akpm@osdl.org \
--to=akpm@osdl.org \
--cc=linux-kernel@vger.kernel.org \
--cc=penberg@cs.helsinki.fi \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®