From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1750877AbVLUQgo (ORCPT ); Wed, 21 Dec 2005 11:36:44 -0500 Received: (majordomo@vger.kernel.org) by vger.kernel.org id S1751135AbVLUQgo (ORCPT ); Wed, 21 Dec 2005 11:36:44 -0500 Received: from pentafluge.infradead.org ([213.146.154.40]:178 "EHLO pentafluge.infradead.org") by vger.kernel.org with ESMTP id S1750877AbVLUQgn (ORCPT ); Wed, 21 Dec 2005 11:36:43 -0500 Date: Wed, 21 Dec 2005 16:36:39 +0000 From: Christoph Hellwig To: Ingo Molnar Cc: Linus Torvalds , lkml , Andrew Morton , Arjan van de Ven , Jes Sorensen , Zwane Mwaikambo , Oleg Nesterov , David Howells , Alan Cox , Benjamin LaHaise , Steven Rostedt , Christoph Hellwig , Andi Kleen , Russell King , Nicolas Pitre , linux-xfs@oss.sgi.com Subject: Re: [patch 1/8] mutex subsystem, XFS namespace collision fixes Message-ID: <20051221163639.GA9735@infradead.org> Mail-Followup-To: Christoph Hellwig , Ingo Molnar , Linus Torvalds , lkml , Andrew Morton , Arjan van de Ven , Jes Sorensen , Zwane Mwaikambo , Oleg Nesterov , David Howells , Alan Cox , Benjamin LaHaise , Steven Rostedt , Andi Kleen , Russell King , Nicolas Pitre , linux-xfs@oss.sgi.com References: <20051221155426.GB7243@elte.hu> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20051221155426.GB7243@elte.hu> User-Agent: Mutt/1.4.2.1i X-SRS-Rewrite: SMTP reverse-path rewritten from by pentafluge.infradead.org See http://www.infradead.org/rpr.html Sender: linux-kernel-owner@vger.kernel.org X-Mailing-List: linux-kernel@vger.kernel.org On Wed, Dec 21, 2005 at 04:54:26PM +0100, Ingo Molnar wrote: > Fixup the XFS code to avoid name clashing with the mutex code by > introducing xfs_mutex_ functions. > > Signed-off-by: Jes Sorensen > Signed-off-by: Ingo Molnar > > ---- > > fs/xfs/linux-2.6/mutex.h | 10 +++++----- > fs/xfs/quota/xfs_dquot.c | 12 ++++++------ > fs/xfs/quota/xfs_dquot.h | 4 ++-- > fs/xfs/quota/xfs_qm.c | 20 ++++++++++---------- > fs/xfs/quota/xfs_qm.h | 4 ++-- > fs/xfs/quota/xfs_qm_bhv.c | 2 +- > fs/xfs/quota/xfs_qm_syscalls.c | 24 ++++++++++++------------ > fs/xfs/quota/xfs_quota_priv.h | 8 ++++---- > fs/xfs/support/uuid.c | 12 ++++++------ > fs/xfs/xfs_mount.c | 4 ++-- > fs/xfs/xfs_mount.h | 4 ++-- > 11 files changed, 52 insertions(+), 52 deletions(-) > > Index: linux/fs/xfs/linux-2.6/mutex.h > =================================================================== > --- linux.orig/fs/xfs/linux-2.6/mutex.h > +++ linux/fs/xfs/linux-2.6/mutex.h > @@ -30,10 +30,10 @@ > #define MUTEX_DEFAULT 0x0 > typedef struct semaphore mutex_t; > > -#define mutex_init(lock, type, name) sema_init(lock, 1) > -#define mutex_destroy(lock) sema_init(lock, -99) > -#define mutex_lock(lock, num) down(lock) > -#define mutex_trylock(lock) (down_trylock(lock) ? 0 : 1) > -#define mutex_unlock(lock) up(lock) > +#define xfs_mutex_init(lock, type, name) arch_sema_init(lock, 1) > +#define xfs_mutex_destroy(lock) arch_sema_init(lock, -99) > +#define xfs_mutex_lock(lock, num) arch_down(lock) > +#define xfs_mutex_trylock(lock) (arch_down_trylock(lock) ? 0 : 1) > +#define xfs_mutex_unlock(lock) arch_up(lock) As the name implies these use mutex xsemantics, just remove the defines and use mutex_lock/mutex_unlock and mutex_trylock directly (the latter only if mutex_trylock has the same return value as spin_trylock, not the broken down_trylock version) not sure what to do about mutex_init, do you have one in your patches? mutex_destroy should be a simple no-op.