From: Nick Piggin <npiggin@suse.de>
To: Joel Schopp <jschopp@austin.ibm.com>
Cc: Nick Piggin <npiggin@suse.de>, Linus Torvalds <torvalds@osdl.org>,
Andrew Morton <akpm@osdl.org>,
Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: [patch 2/2] powerpc: native atomic_add_unless
Date: Wed, 18 Jan 2006 18:28:23 +0100 [thread overview]
Message-ID: <20060118172822.GG28418@wotan.suse.de> (raw)
In-Reply-To: <43CE76B8.1000905@austin.ibm.com>
On Wed, Jan 18, 2006 at 11:11:20AM -0600, Joel Schopp wrote:
> >I didn't convert LL/SC architectures so as to "encourage" them
> >to do atomic_add_unless natively. Here is my probably-wrong attempt
> >for powerpc.
> >
> >Should I bring this up on the arch list? (IIRC cross posting
> >between there and lkml is discouraged)
> >
>
> You should bring this up on the arch list or it is likely to be missed by
> people who would give you useful feedback.
>
OK I will if we don't get much discussion going here.
> >+static __inline__ int atomic_add_unless(atomic_t *v, int a, int u)
> >+{
> >+ int t;
> >+ int dummy;
> >+
> >+ __asm__ __volatile__ (
> >+ LWSYNC_ON_SMP
>
> I realize to preserve the behavior you currently get with the cmpxchg
> currently used to implement atomic_add_unless that you feel the need to put
> in an lwsync & isync. But I would point out that neither is necessary to
> actually atomic add unless. They are simply so cmpxchg can be overloaded
> to be used as both a lock and unlock primitive. If atomic_add_unless isn't
> being used as a locking primitive somewhere I would love for these to be
> dropped.
>
Well my aim is more to fit in with Documentation/atomic_ops.txt which
basically defines every atomic_xxx function which both modifies the
value and returns something as having a memory barrier either side of it.
I do agree that this is probably overkill (though simple). For example
the dec_and_test common to most refcounting tends not to be a barrier.
> >+"1: lwarx %0,0,%2 # atomic_add_unless\n\
> >+ cmpw 0,%0,%4 \n\
>
> This is just personal preference, but I find it more readable to use the
> simplified mnemonic:
> cmpw %0, %4
>
OK. The former appears to be common in atomic.h for some reason... but
I'd be happy to defer that to the maintainers.
> >+ beq- 2f \n\
> >+ add %1,%3,%0 \n"
>
> Why use a separate register here? Why not reuse %0 instead of using %1?
> Registers are valuable.
>
You still need to get the output (t) because you need to return
whether the operation met with the "unless" case or not. If there is
a better way to do this then I'd like to know.
I couldn't even get it to assign a general register without the dummy
variable - my gcc inline asm is pretty rusty.
Thanks for the feedback,
Nick
next prev parent reply other threads:[~2006-01-18 17:28 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2006-01-18 6:36 [patch 1/2] atomic_add_unless sadness Nick Piggin
2006-01-18 6:39 ` [patch 2/2] powerpc: native atomic_add_unless Nick Piggin
2006-01-18 17:11 ` Joel Schopp
2006-01-18 17:28 ` Nick Piggin [this message]
2006-01-18 21:05 ` Joel Schopp
2006-01-19 14:04 ` Nick Piggin
2006-01-18 16:48 ` [patch 1/2] atomic_add_unless sadness Linus Torvalds
2006-01-18 17:10 ` Nick Piggin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20060118172822.GG28418@wotan.suse.de \
--to=npiggin@suse.de \
--cc=akpm@osdl.org \
--cc=jschopp@austin.ibm.com \
--cc=linux-kernel@vger.kernel.org \
--cc=torvalds@osdl.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®