From: "Rafael J. Wysocki" <rjw@sisk.pl>
To: Andrew Morton <akpm@osdl.org>
Cc: pavel@suse.cz, linux-kernel@vger.kernel.org
Subject: Re: [PATCH -mm] swsusp: userland interface (rev 2)
Date: Wed, 25 Jan 2006 00:35:38 +0100 [thread overview]
Message-ID: <200601250035.39383.rjw@sisk.pl> (raw)
In-Reply-To: <20060124131312.0545262d.akpm@osdl.org>
Hi,
On Tuesday, 24 January 2006 22:13, Andrew Morton wrote:
> "Rafael J. Wysocki" <rjw@sisk.pl> wrote:
> >
> > Hi,
> >
> > This patch introduces a user space interface for swsusp.
>
> How will we know if/when this feature is ready for mainline? What criteria
> can we use to judge that?
I think when we are able to demonstrate that it allows us to do more than
the current built-in swsusp in terms of performance, security etc. Of course
we'll need some userland utilities for this purpose.
> Will you be developing and long-term maintaining the userspace tools?
Yes.
> Is it your expectation/hope that distros will migrate onto using them? etc.
I think they'll find the interface useful. I've been using it for a couple of
weeks now and it really allowed me to do some tricks that are just impossible
with the current implementation.
> > +
> > +static int snapshot_open(struct inode *inode, struct file *filp)
> > +{
> > + struct snapshot_data *data;
> > +
> > + if (!atomic_dec_and_test(&device_available)) {
> > + atomic_inc(&device_available);
>
> You may find that atomic_add_unless(..., -1, ...) is neater here, and
> closes the tiny race.
Well, actually I've taken this stuff verbatim from LDD3.
> > + return -EBUSY;
> > + }
> > +
> > + if ((filp->f_flags & O_ACCMODE) == O_RDWR)
> > + return -ENOSYS;
> > +
> > + nonseekable_open(inode, filp);
> > + data = &snapshot_state;
> > + filp->private_data = data;
> > + memset(&data->handle, 0, sizeof(struct snapshot_handle));
>
> <goes off hunting elsewhere for the defn of data->handle. grr>
>
> > +static ssize_t snapshot_read(struct file *filp, char __user *buf,
> > + size_t count, loff_t *offp)
> > +{
> > + struct snapshot_data *data;
> > + ssize_t res;
> > +
> > + data = filp->private_data;
> > + res = snapshot_read_next(&data->handle, count);
> > + if (res > 0) {
> > + if (copy_to_user(buf, data_of(data->handle), res))
> > + res = -EFAULT;
> > + else
> > + *offp = data->handle.offset;
> > + }
> > + return res;
> > +}
>
> It's more conventional for a read() to return less-than-was-asked-for when
> it hits a fault. Doesn't matter though - lots of drivers do it this way.
I thought about it, but this would increase the complexity of
snapshot_read_next() by two orders of magnitude, and this function is also
called by the built-in code which doesn't use the read-less-than-one-page-at-a-time
functionality anyway, so I decided against it.
> > +static ssize_t snapshot_write(struct file *filp, const char __user *buf,
> > + size_t count, loff_t *offp)
> > +{
> > + struct snapshot_data *data;
> > + ssize_t res;
> > +
> > + data = filp->private_data;
> > + res = snapshot_write_next(&data->handle, count);
> > + if (res > 0) {
> > + if (copy_from_user(data_of(data->handle), buf, res))
> > + res = -EFAULT;
> > + else
> > + *offp = data->handle.offset;
> > + }
> > + return res;
> > +}
>
> Ditto.
>
> > +static int snapshot_ioctl(struct inode *inode, struct file *filp,
> > + unsigned int cmd, unsigned long arg)
> > +{
> >
> > ...
> >
> > + case SNAPSHOT_ATOMIC_RESTORE:
> > + if (data->mode != O_WRONLY || !data->frozen ||
> > + !snapshot_image_loaded(&data->handle)) {
> > + error = -EPERM;
> > + break;
> > + }
> > + down(&pm_sem);
> > + pm_prepare_console();
> > + error = device_suspend(PMSG_FREEZE);
> > + if (!error) {
> > + mb();
> > + error = swsusp_resume();
> > + device_resume();
> > + }
>
> whee, what does the mystery barrier do? It'd be nice to comment this
> (please always comment open-coded barriers).
Pavel should know. ;-)
> > + case SNAPSHOT_GET_SWAP_PAGE:
> > + if (!access_ok(VERIFY_WRITE, (unsigned long __user *)arg, _IOC_SIZE(cmd))) {
> > + error = -EINVAL;
> > + break;
> > + }
>
> Why do we need an access_ok() here?
Because we use __put_user() down the road?
The problem is if the address is wrong we should not try to call
alloc_swap_page() at all. If we did, we wouldn't be able to return the result
and we would leak a swap page.
> Should it return -EFAULT?
Yes, it should.
I'll post a small fix on top of this patch if you don't mind.
next prev parent reply other threads:[~2006-01-25 0:11 UTC|newest]
Thread overview: 25+ messages / expand[flat|nested] mbox.gz Atom feed top
2006-01-24 8:29 Rafael J. Wysocki
2006-01-24 11:14 ` Pavel Machek
2006-01-24 21:13 ` Andrew Morton
2006-01-24 21:30 ` Pavel Machek
2006-01-24 21:58 ` Andrew Morton
2006-01-24 22:14 ` Pavel Machek
2006-01-24 22:20 ` Dave Jones
2006-01-24 22:33 ` Pavel Machek
2006-01-24 22:38 ` Dave Jones
2006-01-24 22:44 ` Pavel Machek
2006-01-26 2:09 ` Jim Crilly
2006-01-26 7:58 ` Pavel Machek
2006-01-27 1:11 ` Greg KH
2006-01-27 3:42 ` Kay Sievers
2006-01-27 11:24 ` Rafael J. Wysocki
2006-01-24 22:47 ` Lee Revell
2006-01-24 23:53 ` Rafael J. Wysocki
2006-01-25 0:17 ` Andrew Morton
2006-01-25 0:31 ` Rafael J. Wysocki
2006-01-24 23:35 ` Rafael J. Wysocki [this message]
2006-01-25 2:46 ` Benjamin LaHaise
2006-01-25 10:50 ` Rafael J. Wysocki
2006-01-25 12:18 ` Pavel Machek
2006-01-25 12:29 ` Rafael J. Wysocki
2006-01-25 12:20 ` Pavel Machek
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=200601250035.39383.rjw@sisk.pl \
--to=rjw@sisk.pl \
--cc=akpm@osdl.org \
--cc=linux-kernel@vger.kernel.org \
--cc=pavel@suse.cz \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome