Hi. On Wednesday 01 February 2006 22:38, Pekka Enberg wrote: > On 2/1/06, Nigel Cunningham wrote: > > The name is currently mostly historical, from the time when these > > components could be built as kernel modules. > > I think suspend_plugin would be a nicer name. Your code is even using > the term 'plugin' and 'filter' instead of module in many places. Hmm. Thought I got rid of all mentions of 'plugin'. I was trying to follow Dave M's advice from LCA :). Filters are slightly different - they're the modules that do the encryption or compression, as opposed to the writers that do the I/O. Regards, Nigel -- See our web page for Howtos, FAQs, the Wiki and mailing list info. http://www.suspend2.net IRC: #suspend2 on Freenode