From: Edgar Toernig <froese@gmx.de>
To: mchehab@infradead.org
Cc: linux-kernel@vger.kernel.org, linux-dvb-maintainer@linuxtv.org,
Manu Abraham <manu@linuxtv.org>,
Mauro Carvalho Chehab <mchehab@infradead.org>
Subject: Re: [PATCH 04/16] Fix [Bug 5895] to correct snd_87x autodetect
Date: Wed, 8 Feb 2006 01:24:34 +0100 [thread overview]
Message-ID: <20060208012434.10d927c4.froese@gmx.de> (raw)
In-Reply-To: <20060207153330.PS44220900004@infradead.org>
mchehab@infradead.org wrote:
>
> --- a/drivers/media/dvb/bt8xx/bt878.c
> +++ b/drivers/media/dvb/bt8xx/bt878.c
> @@ -381,6 +381,23 @@ bt878_device_control(struct bt878 *bt, u
>
> EXPORT_SYMBOL(bt878_device_control);
>
> +
> +struct cards card_list[] __devinitdata = {
> +
> + { 0x01010071, BTTV_BOARD_NEBULA_DIGITV, "Nebula Electronics DigiTV" },
> + { 0x07611461, BTTV_BOARD_AVDVBT_761, "AverMedia AverTV DVB-T 761" },
>[...]
I'm not very familiar with the pci configuration logic but
what's the point of this list and the BTTV_BOARD_xxx defines?
The defines are never used and the list is only used to let
the probe routine fail when the device is not in the list.
Wouldn't it be cleaner to add them to the pci_device_id
list further down instead of requesting all subsystem ids?
| static struct pci_device_id bt878_pci_tbl[] __devinitdata = {
| {PCI_VENDOR_ID_BROOKTREE, PCI_DEVICE_ID_BROOKTREE_878,
| PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0},
| {0,}
| };
Anyway, the bttv driver already has this information in his card
list (field has_dvb). As long as the bt878 isn't stand alone
and requires the bttv driver wouldn't it be better to query its
table?
Even if this table is kept, it should be static and the variable
card_id in the probe routine should be renamed to pci_id as it
does not hold the card_id as defined in struct card but the pci_id.
Ciao, ET.
next prev parent reply other threads:[~2006-02-08 0:24 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2006-02-07 15:32 [PATCH 00/16] V4L/DVB updates mchehab
2006-02-07 15:33 ` [PATCH 02/16] Fix NICAM buzz on analog sound mchehab
2006-02-07 15:33 ` [PATCH 01/16] Kconfig: DVB_USB_CXUSB depends on DVB_LGDT330X and DVB_MT352 mchehab
2006-02-07 15:33 ` [PATCH 03/16] Added signal detection support to tvp5150 mchehab
2006-02-07 15:33 ` [PATCH 05/16] Add IR support to KWorld DVB-T (cx22702-based) mchehab
2006-02-07 15:33 ` [PATCH 04/16] Fix [Bug 5895] to correct snd_87x autodetect mchehab
2006-02-08 0:24 ` Edgar Toernig [this message]
2006-02-08 1:08 ` Manu Abraham
2006-02-07 15:33 ` [PATCH 06/16] Add standard for South Korean NTSC-M using A2 audio mchehab
2006-02-07 15:33 ` [PATCH 07/16] Fixed i2c return value, conversion mdelay to msleep mchehab
2006-02-07 20:52 ` [v4l-dvb-maintainer] " Andreas Oberritter
2006-02-07 21:49 ` Markus Rechberger
2006-02-07 15:33 ` [PATCH 08/16] Support for Galaxis DVB-S rev1.3 mchehab
2006-02-07 15:33 ` [PATCH 09/16] Use parallel transport for FusionHDTV Dual Digital USB mchehab
2006-02-07 15:33 ` [PATCH 10/16] Use MT352 parallel transport function for all Bluebird FusionHDTV DVB-T boxes mchehab
2006-02-07 15:33 ` [PATCH 11/16] FIX: Multiple usage of VP7045-based devices mchehab
2006-02-07 15:33 ` [PATCH 12/16] FIX: Check if FW was downloaded or not + new firmware file mchehab
2006-02-07 15:33 ` [PATCH 14/16] fix saa7146 kobject register failure mchehab
2006-02-07 15:33 ` [PATCH 13/16] Makes Some symbols static mchehab
2006-02-07 15:33 ` [PATCH 15/16] DVB: remove the at76c651/tda80xx frontends mchehab
2006-02-07 15:33 ` [PATCH 16/16] Disabled debug on by default in tvp5150 mchehab
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20060208012434.10d927c4.froese@gmx.de \
--to=froese@gmx.de \
--cc=linux-dvb-maintainer@linuxtv.org \
--cc=linux-kernel@vger.kernel.org \
--cc=manu@linuxtv.org \
--cc=mchehab@infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome