mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Andrew Morton <akpm@osdl.org>
To: Ingo Molnar <mingo@elte.hu>
Cc: linux-kernel@vger.kernel.org, tglx@linutronix.de,
	torvalds@osdl.org, arjan@infradead.org
Subject: Re: [patch 04/10] PI-futex: scheduler support for PI
Date: Sat, 25 Mar 2006 19:03:49 -0800	[thread overview]
Message-ID: <20060325190349.6b8fe5f3.akpm@osdl.org> (raw)
In-Reply-To: <20060325184605.GE16724@elte.hu>

Ingo Molnar <mingo@elte.hu> wrote:
>
> From: Ingo Molnar <mingo@elte.hu>
> 
> add framework to boost/unboost the priority of RT tasks.
> 
> This consists of:
> 
>  - caching the 'normal' priority in ->normal_prio
>  - providing a functions to set/get the priority of the task
>  - make sched_setscheduler() aware of boosting
> 
> ...
>
> +#ifdef CONFIG_RT_MUTEXES
> +
> +/*
> + * rt_mutex_setprio - set the current priority of a task
> + * @p: task
> + * @prio: prio value (kernel-internal form)
> + *
> + * This function changes the 'effective' priority of a task. It does
> + * not touch ->normal_prio like __setscheduler().
> + *
> + * Used by the rt_mutex code to implement priority inheritance logic.
> + */
> +void rt_mutex_setprio(task_t *p, int prio)
> +{

This function is not really rt-mutex-related at all, is it?  It's just a
piece of new scheduler functionality which various things might use.

If so, it should be named something non-mutexy and should be under a
different CONFIG_option which CONFIG_RT_MUTEXES selects.

Of course, we can do all that later on, if/when something else needs this
facility.


  reply	other threads:[~2006-03-26  3:07 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2006-03-25 18:46 Ingo Molnar
2006-03-26  3:03 ` Andrew Morton [this message]
2006-03-26 16:24   ` Ingo Molnar

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20060325190349.6b8fe5f3.akpm@osdl.org \
    --to=akpm@osdl.org \
    --cc=arjan@infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    --cc=tglx@linutronix.de \
    --cc=torvalds@osdl.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®