On Monday 24 April 2006 23:50, you wrote: > Oh, and yeah, a = b + c *is* more readable than > > a = malloc(strlen(b) + strlen(c)); > strcpy(a,b); > strcat(a,c); > > and contains fewer bugs ;) and a hidden memory allocation. Which GFP flag would you use for the allocation? (And how would you actually _pass_ it) GFP_KERNEL? Good luck, if you see a a = b + c; in atomic context. GFP_ATOMIC? Well, we both don't want that. Checking is_atomic() and deciding upon that? I call that overhead... . -- Greetings Michael.