From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S965057AbWD0S6T (ORCPT ); Thu, 27 Apr 2006 14:58:19 -0400 Received: (majordomo@vger.kernel.org) by vger.kernel.org id S965019AbWD0S6T (ORCPT ); Thu, 27 Apr 2006 14:58:19 -0400 Received: from 10.121.9.213.dsl.getacom.de ([213.9.121.10]:27577 "EHLO localhost.localdomain") by vger.kernel.org with ESMTP id S965014AbWD0S6S (ORCPT ); Thu, 27 Apr 2006 14:58:18 -0400 Date: Thu, 27 Apr 2006 20:58:14 +0200 From: jdi@l4x.org To: jgarzik@pobox.com Cc: jdi@l4x.org, linux-ide@vger.kernel.org, linux-kernel@vger.kernel.org Subject: sata_sil24 resetting controller... Message-ID: <20060427185813.GB6039@l4x.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline User-Agent: Mutt/1.5.11+cvs20060403 Sender: linux-kernel-owner@vger.kernel.org X-Mailing-List: linux-kernel@vger.kernel.org Hello, I just received a DawiControl DC-4300 SATA-2 RAID card (sil3124 based) together with a Western Digital WD3200KS hard drive which should support sata2 and ncq in its full glory. Basic read/write tests with dd went ok, so I started to reshape my raid5 array. Since the reshape started my kernel log gets swamped with the following messages: [4297871.909000] sata_sil24 ata1: resetting controller... [4297871.909000] ata1: status=0x50 { DriveReady SeekComplete } [4297871.909000] sdc: Current: sense key=0x0 [4297871.909000] ASC=0x0 ASCQ=0x0 [4297873.266000] ata1: error interrupt on port0 [4297873.266000] stat=0x80000001 irq=0xb60002 cmd_err=35 sstatus=0x123 serror=0x0[4297873.266000] sata_sil24 ata1: resetting controller... [4297873.267000] ata1: status=0x50 { DriveReady SeekComplete } [4297873.267000] sdc: Current: sense key=0x0 [4297873.267000] ASC=0x0 ASCQ=0x0 The time between these events varies from .5s to up to 10s, resync speed is pretty bad (6mb/s) but appears(!) to be working. This is with vanilla 2.6.17-rc3, sata drivers built into the kernel. Find below /proc/interrupts and lspci output. Boot dmesg output was washed away by above messages, sorry. What's the cause of the error, can I ignore it or will it destroy my raid eventually? I'm now about 5% through the resync process, with an estimated finish in 1260 minutes. Thanks, Jan $ lspci -vv -s 03:04.0 0000:03:04.0 RAID bus controller: Silicon Image, Inc. SiI 3124 PCI-X Serial ATA Controller (rev 01) Subsystem: Silicon Image, Inc.: Unknown device 7124 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping+ SERR- FastB2B- Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- SERR-