mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Doug Thompson <norsk5@yahoo.com>
To: Andrew Morton <akpm@osdl.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: [PATCH 0/6]  EDAC Patch Set
Date: Wed, 24 May 2006 10:43:03 -0700 (PDT)	[thread overview]
Message-ID: <20060524174303.2323.qmail@web50102.mail.yahoo.com> (raw)

This patch set applies to kernel 2.6.17-rc4 fine and to 2.6.17-rc4-mm1 with slight
fuzz in the MAINTAINERs file.

The following set of patches to EDAC provide various cleanups of the EDAC core and
memory controller drivers.  Most of which came from Dave Peterson and from others.

edac-pci_dep.patch
Change MC drivers from using CVS revisions strings for their version number,
Now each driver has its own local string.

Remove some PCI dependencies from the core EDAC module.  Most of the code
changes here are from a patch by Dave Jiang.
It may be best to eventually move the PCI-specific code into a separate source file.

edac-mc_numbers_1_of_2.patch
This is part 1 of a 2-part patch set.  The code changes are split into two
parts to make the patches more readable.

Remove add_mc_to_global_list().  In next patch, this function will be
reimplemented with different semantics.

edac-mc_numbers_2_of_2.patch
This is part 2 of a 2-part patch set.

- Reimplement add_mc_to_global_list() with semantics that allow the caller to
  determine the ID number for a mem_ctl_info structure.  Then modify
  edac_mc_add_mc() so that the caller specifies the ID number for the new
  mem_ctl_info structure.  Platform-specific code should be able to assign the
  ID numbers in a platform-specific manner.  For instance, on Opteron it makes
  sense to have the ID of the mem_ctl_info structure match the ID of the node
  that the memory controller belongs to.

- Modify callers of edac_mc_add_mc() so they use the new semantics.

edac-probe1_cleanup_1_of_2.patch
This is part 1 of a 2-part patch set.  The code changes are split into two
parts to make the patches more readable.

Add lower-level functions that handle various parts of the initialization done
by the xxx_probe1() functions.  Some of the xxx_probe1() functions are much
too long and complicated (see "Chapter 5: Functions" in
Documentation/CodingStyle).
This is part 2 of a 2-part patch set.

Modify the xxx_probe1() functions so they call the lower-level functions
created by the first patch in the set.

edac-maintainers.patch
--------
Removed Dave Peterson as per his request as maintainer.
Add Mark Gross as maintainer for E752X MC driver

Signed-off-by:  doug thompson <norsk5@xmission.com>

 drivers/edac/amd76x_edac.c                   |   97 ++++---
 drivers/edac/e752x_edac.c                    |  345 ++++++++++++++-------------
 drivers/edac/e7xxx_edac.c                    |  184 +++++++-------
 drivers/edac/edac_mc.c                       |   56 ++--
 drivers/edac/edac_mc.h                       |   20 +
 drivers/edac/i82860_edac.c                   |  132 +++++-----
 drivers/edac/i82875p_edac.c                  |  254 +++++++++++--------
 drivers/edac/r82600_edac.c                   |  139 +++++-----
 linux-2.6.17-rc3/drivers/edac/edac_mc.c      |   43 ---
 linux-2.6.17-rc4/MAINTAINERS                 |   14 -
 linux-2.6.17-rc4/drivers/edac/amd76x_edac.c  |    5 
 linux-2.6.17-rc4/drivers/edac/e752x_edac.c   |    5 
 linux-2.6.17-rc4/drivers/edac/e7xxx_edac.c   |    5 
 linux-2.6.17-rc4/drivers/edac/edac_mc.c      |   46 +++
 linux-2.6.17-rc4/drivers/edac/edac_mc.h      |    2 
 linux-2.6.17-rc4/drivers/edac/i82860_edac.c  |    5 
 linux-2.6.17-rc4/drivers/edac/i82875p_edac.c |    5 
 linux-2.6.17-rc4/drivers/edac/r82600_edac.c  |    5 
 18 files changed, 755 insertions(+), 607 deletions(-)


             reply	other threads:[~2006-05-24 17:43 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2006-05-24 17:43 Doug Thompson [this message]
2006-05-24 18:17 ` Jurgen Kramer
2006-05-24 18:55   ` Doug Thompson
2006-05-22 21:34     ` mark gross
2006-05-25  4:42 ` Andrew Morton
2006-05-22 21:35   ` mark gross
2006-06-26 22:15 Doug Thompson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20060524174303.2323.qmail@web50102.mail.yahoo.com \
    --to=norsk5@yahoo.com \
    --cc=akpm@osdl.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome