From: "Rafael J. Wysocki" <rjw@sisk.pl>
To: Andrew Morton <akpm@osdl.org>
Cc: LKML <linux-kernel@vger.kernel.org>, Pavel Machek <pavel@ucw.cz>
Subject: [PATCH -mm 1/5] Clean up suspend header
Date: Thu, 10 Aug 2006 15:12:02 +0200 [thread overview]
Message-ID: <200608101512.02434.rjw@sisk.pl> (raw)
In-Reply-To: <200608101510.40544.rjw@sisk.pl>
Remove some things that are no longer used or defined elsewhere from suspend.h
and make the inline version of software_suspend() return the right error code.
Signed-off-by: Rafael J. Wysocki <rjw@sisk.pl>
---
include/linux/suspend.h | 15 +++------------
1 file changed, 3 insertions(+), 12 deletions(-)
Index: linux-2.6.18-rc3-mm2/include/linux/suspend.h
===================================================================
--- linux-2.6.18-rc3-mm2.orig/include/linux/suspend.h 2006-08-10 00:08:08.000000000 +0200
+++ linux-2.6.18-rc3-mm2/include/linux/suspend.h 2006-08-10 07:43:53.000000000 +0200
@@ -10,11 +10,11 @@
#include <linux/pm.h>
/* page backup entry */
-typedef struct pbe {
+struct pbe {
unsigned long address; /* address of the copy */
unsigned long orig_address; /* original address of page */
struct pbe *next;
-} suspend_pagedir_t;
+};
#define for_each_pbe(pbe, pblist) \
for (pbe = pblist ; pbe ; pbe = pbe->next)
@@ -25,15 +25,6 @@ typedef struct pbe {
#define for_each_pb_page(pbe, pblist) \
for (pbe = pblist ; pbe ; pbe = (pbe+PB_PAGE_SKIP)->next)
-
-#define SWAP_FILENAME_MAXLENGTH 32
-
-
-extern dev_t swsusp_resume_device;
-
-/* mm/vmscan.c */
-extern int shrink_mem(void);
-
/* mm/page_alloc.c */
extern void drain_local_pages(void);
extern void mark_free_pages(struct zone *zone);
@@ -53,7 +44,7 @@ static inline void pm_restore_console(vo
static inline int software_suspend(void)
{
printk("Warning: fake suspend called\n");
- return -EPERM;
+ return -ENOSYS;
}
#endif /* CONFIG_PM */
next prev parent reply other threads:[~2006-08-10 13:27 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2006-08-10 13:10 [PATCH -mm 0/5] Cleanups and improvements related to swsusp Rafael J. Wysocki
2006-08-10 13:12 ` Rafael J. Wysocki [this message]
2006-08-10 13:16 ` [PATCH -mm 2/5] Change the name of pagedir_nosave Rafael J. Wysocki
2006-08-10 13:18 ` [PATCH -mm 3/5] swsusp: Introduce some helpful constants Rafael J. Wysocki
2006-08-10 13:21 ` [PATCH -mm 4/5] swsusp: Introduce memory bitmaps Rafael J. Wysocki
2006-08-10 13:23 ` [PATCH -mm 5/5] swsusp: Use memory bitmaps during resume Rafael J. Wysocki
2006-08-13 22:04 ` Andrew Morton
2006-08-14 9:00 ` Rafael J. Wysocki
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=200608101512.02434.rjw@sisk.pl \
--to=rjw@sisk.pl \
--cc=akpm@osdl.org \
--cc=linux-kernel@vger.kernel.org \
--cc=pavel@ucw.cz \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®