From: Andrew Morton <akpm@osdl.org>
To: Adrian Bunk <bunk@stusta.de>
Cc: Stephen Hemminger <shemminger@osdl.org>,
linux-kernel@vger.kernel.org,
Stephane Eranian <eranian@hpl.hp.com>,
sam@ravnborg.org
Subject: Re: [PATCH] rename net_random to random32
Date: Fri, 13 Oct 2006 12:09:56 -0700 [thread overview]
Message-ID: <20061013120956.962a569a.akpm@osdl.org> (raw)
In-Reply-To: <20061013181922.GB721@stusta.de>
On Fri, 13 Oct 2006 20:19:22 +0200
Adrian Bunk <bunk@stusta.de> wrote:
> On Thu, Oct 12, 2006 at 10:26:38AM -0700, Stephen Hemminger wrote:
> >
> > Make net_random() more widely available by calling it random32
> >...
> > --- a/lib/Makefile
> > +++ b/lib/Makefile
> > @@ -5,7 +5,7 @@ #
> > lib-y := ctype.o string.o vsprintf.o cmdline.o \
> > bust_spinlocks.o rbtree.o radix-tree.o dump_stack.o \
> > idr.o div64.o int_sqrt.o bitmap.o extable.o prio_tree.o \
> > - sha1.o irq_regs.o carta_random32.o
> > + sha1.o irq_regs.o random32.o carta_random32.o
> >...
> > --- /dev/null
> > +++ b/lib/random32.c
> >...
> > +EXPORT_SYMBOL(random32);
> >...
> > +EXPORT_SYMBOL(srandom32);
> >...
>
> EXPORT_SYMBOL's in lib-y are latent bugs (IMHO kbuild should error
> on them):
>
> The problem is that if only modules use these functions, they will be
> omitted from the kernel image.
>
Yeah, I always get those two confused. I moved it to obj-y, thanks.
next prev parent reply other threads:[~2006-10-13 19:19 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <200610111900.k9BJ01M4021853@hera.kernel.org>
2006-10-11 19:22 ` [PATCH] Add carta_random32() library routine Jeff Garzik
2006-10-11 19:29 ` Stephen Hemminger
2006-10-12 7:07 ` Andrew Morton
2006-10-12 17:26 ` [PATCH] rename net_random to random32 Stephen Hemminger
2006-10-12 21:43 ` David Miller
2006-10-13 18:19 ` Adrian Bunk
2006-10-13 18:28 ` Stephen Hemminger
2006-10-13 19:09 ` Andrew Morton [this message]
2006-10-13 22:14 ` David Miller
2006-10-14 10:41 ` Sam Ravnborg
2006-10-28 16:46 ` Christoph Hellwig
2006-10-11 19:39 ` [PATCH] Add carta_random32() library routine Andrew Morton
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20061013120956.962a569a.akpm@osdl.org \
--to=akpm@osdl.org \
--cc=bunk@stusta.de \
--cc=eranian@hpl.hp.com \
--cc=linux-kernel@vger.kernel.org \
--cc=sam@ravnborg.org \
--cc=shemminger@osdl.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome