mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Andrew Morton <akpm@osdl.org>
To: Haavard Skinnemoen <hskinnemoen@atmel.com>
Cc: David Brownell <david-b@pacbell.net>,
	Andrew Victor <andrew@sanpeople.com>,
	Linux Kernel <linux-kernel@vger.kernel.org>
Subject: Re: [-mm patch 1/4] GPIO framework for AVR32
Date: Tue, 7 Nov 2006 13:10:14 -0800	[thread overview]
Message-ID: <20061107131014.535ab280.akpm@osdl.org> (raw)
In-Reply-To: <20061107122715.3022da2f@cad-250-152.norway.atmel.com>

On Tue, 7 Nov 2006 12:27:15 +0100
Haavard Skinnemoen <hskinnemoen@atmel.com> wrote:

> Add a simple GPIO framework for AVR32. This should be fairly similar
> to the AT91 GPIO API, but there are still a couple of differences:
> 
>   * Naming. We prefix all functions with gpio_ instead of at91_
>   * request_gpio() and free_gpio() should be called to make sure
>     the required pins are available, but it will still work if you
>     don't.

+EXPORT_SYMBOL(request_gpio);
+EXPORT_SYMBOL(free_gpio);
+EXPORT_SYMBOL(gpio_set_value);
+EXPORT_SYMBOL(gpio_get_value);
+EXPORT_SYMBOL(gpio_set_output_enable);
+EXPORT_SYMBOL(gpio_set_pullup_enable);

I wonder about this naming choice.  I'd have though that if/when the kernel
gets a generic GPIO driver or layer, these avr32-specific symbols will need
renaming.

h8300 uses h8300_free_gpio(), and there's also omap_free_gpio().  Perhaps
this patch should have added avr32_free_gpio()?


  parent reply	other threads:[~2006-11-07 21:10 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2006-11-07 11:25 [-mm patch 0/4] Atmel SPI driver and related AVR32 changes Haavard Skinnemoen
2006-11-07 11:27 ` [-mm patch 1/4] GPIO framework for AVR32 Haavard Skinnemoen
2006-11-07 11:31   ` [-mm patch 2/4] AVR32: spi/ethernet platform_device update Haavard Skinnemoen
2006-11-07 11:33     ` [-mm patch 3/4] AVR32: Move spi device definitions into main board setup file Haavard Skinnemoen
2006-11-07 11:41       ` [-mm patch 4/4] Atmel SPI driver Haavard Skinnemoen
2006-11-07 14:12         ` [-mm patch 5/4] Atmel SPI driver: MAINTAINERS entry Haavard Skinnemoen
2006-11-07 21:10   ` Andrew Morton [this message]
2006-11-07 22:37     ` [-mm patch 1/4] GPIO framework for AVR32 David Brownell
2006-11-08 11:48       ` Haavard Skinnemoen
2006-11-08 18:00         ` David Brownell
2006-11-08 18:57           ` Haavard Skinnemoen
2006-11-08 22:12             ` David Brownell
2006-11-08 22:47               ` Haavard Skinnemoen
2006-11-09  7:26           ` Andrew Victor
2006-11-09 20:41             ` [Bulk] " David Brownell
2006-11-07 21:36   ` David Brownell
2006-11-08 10:30     ` Haavard Skinnemoen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20061107131014.535ab280.akpm@osdl.org \
    --to=akpm@osdl.org \
    --cc=andrew@sanpeople.com \
    --cc=david-b@pacbell.net \
    --cc=hskinnemoen@atmel.com \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®