mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Cornelia Huck <cornelia.huck@de.ibm.com>
To: Benjamin Herrenschmidt <benh@au1.ibm.com>
Cc: Linux Kernel list <linux-kernel@vger.kernel.org>,
	Len Brown <len.brown@intel.com>, Andrew Morton <akpm@osdl.org>,
	Greg KH <greg@kroah.com>
Subject: Re: [PATCH 0/2] Add dev_sysdata and use it for ACPI
Date: Thu, 9 Nov 2006 17:04:35 +0100	[thread overview]
Message-ID: <20061109170435.07d2e0c4@gondolin.boeblingen.de.ibm.com> (raw)
In-Reply-To: <1163033121.28571.792.camel@localhost.localdomain>

On Thu, 09 Nov 2006 11:45:21 +1100,
Benjamin Herrenschmidt <benh@au1.ibm.com> wrote:

>  - Add a dev_sysdata structure to struct device whose content is arch
> specific. It will allow architectures like powerpc, arm, i386, ... who
> need different types of DMA ops for busses and other kind of auxilliary
> data for devices in general (numa node id, firmware data, etc...) to put
> them in there, without bloating all architectures. The patch adds an
> empty definition for the structure to all architectures.

I like this. If we could move the dma stuff in there, we could get rid
of it on s390 where it is just bloat we drag around...

(Maybe dev_archdata would be a better name, since the definition is
architecture specific?)

-- 
Cornelia Huck
Linux for zSeries Developer
Tel.: +49-7031-16-4837, Mail: cornelia.huck@de.ibm.com

  reply	other threads:[~2006-11-09 16:04 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2006-11-09  0:45 Benjamin Herrenschmidt
2006-11-09 16:04 ` Cornelia Huck [this message]
2006-11-09 22:35   ` Benjamin Herrenschmidt
2006-11-10  5:48     ` Greg KH
2006-11-10  9:44       ` Benjamin Herrenschmidt
2006-11-13  5:17       ` Paul Mackerras
2006-11-13  6:07         ` Benjamin Herrenschmidt

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20061109170435.07d2e0c4@gondolin.boeblingen.de.ibm.com \
    --to=cornelia.huck@de.ibm.com \
    --cc=akpm@osdl.org \
    --cc=benh@au1.ibm.com \
    --cc=greg@kroah.com \
    --cc=len.brown@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®