From: Blaisorblade <blaisorblade@yahoo.it>
To: Pavel Machek <pavel@ucw.cz>
Cc: Andrew Morton <akpm@osdl.org>, Andi Kleen <ak@muc.de>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/2] Make x86_64 udelay() round up instead of down.
Date: Fri, 10 Nov 2006 23:16:19 +0100 [thread overview]
Message-ID: <200611102316.19545.blaisorblade@yahoo.it> (raw)
In-Reply-To: <20061101163043.GA2602@elf.ucw.cz>
Hi Pavel!
On Wednesday 01 November 2006 17:30, Pavel Machek wrote:
> Hi!
>
> > From: Paolo 'Blaisorblade' Giarrusso <blaisorblade@yahoo.it>
> >
> > Port two patches from i386 to x86_64 delay.c to make sure all rounding is
> > done upward instead of downward.
> >
> > There is no sign in commit messages that the mismatch was done on
> > purpose, and "delay() guarantees sleeping at least for the specified
> > time" is still a valid rule IMHO.
> >
> > diff --git a/arch/x86_64/lib/delay.c b/arch/x86_64/lib/delay.c
> > index 50be909..7514df0 100644
> > --- a/arch/x86_64/lib/delay.c
> > +++ b/arch/x86_64/lib/delay.c
> > @@ -40,13 +40,13 @@ EXPORT_SYMBOL(__delay);
> >
> > inline void __const_udelay(unsigned long xloops)
> > {
> > - __delay((xloops * HZ *
> > cpu_data[raw_smp_processor_id()].loops_per_jiffy) >> 32);
> > + __delay((xloops * HZ *
> > cpu_data[raw_smp_processor_id()].loops_per_jiffy) >> 32 + 1);
Btw, that's read as >> (32 + 1). My fault.
> Well, if this should be *rounding* up, you should do
>
> (xloops * HZ * cpu_data[raw_smp_processor_id()].loops_per_jiffy +
> 0xffffffff) >> 32
Indeed, I did it so following i386 code (where fixing this is awkward - doable
with carry sums or 64-bit sums), but it's better this way.
I'd slightly prefer (for readability) (xloops * HZ *
cpu_data[raw_smp_processor_id()].loops_per_jiffy +
(1<<32)-1) >> 32, or even
DIV_ROUND_UP(xloops * HZ * cpu_data[raw_smp_processor_id()].loops_per_jiffy, 1
<< 32)
but kernel.h macros such as that seem to be underused (everything reimplements
them as min() and max() before 2.6) and should be made more consistent in
naming:
#define ALIGN(x,a) (((x)+(a)-1UL)&~((a)-1UL))
#define DIV_ROUND_UP(n,d) (((n) + (d) - 1) / (d))
#define roundup(x, y) ((((x) + ((y) - 1)) / (y)) * (y))
I hope that gcc optimizes well x / (1<<32) to x >> 32, but without assurance I
won't use DIV_ROUND_UP in timer code.
(I also thought there was a bug, so I had a deep look and the difference
between -1 in roundup and -1UL is correct due to sign extension ruining
bitmasks, even if it seemed a bad mismatch).
--
Inform me of my mistakes, so I can keep imitating Homer Simpson's "Doh!".
Paolo Giarrusso, aka Blaisorblade
http://www.user-mode-linux.org/~blaisorblade
Chiacchiera con i tuoi amici in tempo reale!
http://it.yahoo.com/mail_it/foot/*http://it.messenger.yahoo.com
next prev parent reply other threads:[~2006-11-10 22:16 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2006-10-29 20:07 Paolo 'Blaisorblade' Giarrusso
2006-10-29 20:07 ` [PATCH 2/2] i386, x86_64: comment magic constants in delay.h Paolo 'Blaisorblade' Giarrusso
2006-11-01 16:30 ` [PATCH 1/2] Make x86_64 udelay() round up instead of down Pavel Machek
2006-11-10 22:16 ` Blaisorblade [this message]
2006-11-17 19:30 ` [PATCH 1/2] Make x86_64 udelay() round up instead of down - try2 Paolo 'Blaisorblade' Giarrusso
2006-11-17 22:00 ` Andrew Morton
2006-11-17 22:18 ` Blaisorblade
2006-11-17 19:30 ` [PATCH 2/2] i386, x86_64: comment magic constants in delay.h Paolo 'Blaisorblade' Giarrusso
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=200611102316.19545.blaisorblade@yahoo.it \
--to=blaisorblade@yahoo.it \
--cc=ak@muc.de \
--cc=akpm@osdl.org \
--cc=linux-kernel@vger.kernel.org \
--cc=pavel@ucw.cz \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®