mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Oleg Nesterov <oleg@tv-sign.ru>
To: Andrew Morton <akpm@linux-foundation.org>
Cc: Ingo Molnar <mingo@elte.hu>, David Howells <dhowells@redhat.com>,
	linux-kernel@vger.kernel.org
Subject: [PATCH 0/3] delayed_work tweaks
Date: Sun, 11 Feb 2007 00:50:14 +0300	[thread overview]
Message-ID: <20070210215014.GA2210@tv-sign.ru> (raw)

Andrew, unless you stop me right now, I am going to send the following
patches in addition:

	[PATCH] kill cancel_rearming_delayed_workqueue()

		cancel_rearming_delayed_workqueue(wq, dwork) does not
		need the first parameter, it could be figured out from
		dwork. So we can rename it to cancel_rearming_delayed_work
		after the simple change and fix all callers.

		In other words:

			- cancel_rearming_delayed_work(dwork) will work
			  for any workqueue, not just keventd_wq.

			- all callers of cancel_rearming_delayed_workqueue()
			  will be converted to use it.

		No? This breaks the public interface, but we already did
		this recently ...

	[PATCH] kill flush_work_keventd()

		The same is true for flush_work(), it doesn't need the
		"struct workqueue_struct *wq" parameter. I missed this
		fact when I was doing flush_work().

		This change is obviously good to do before flush_work()
		goes to mainline.

		Also, I think the name "flush_work" is very bad. Isn't
		it better to rename it as well?

		cancel_work? cancel_work_sync? whatever.

	[PATCH] bonus: mark kernel/workqueue.c as CONFIG_EXPERIMENTAL

		too many non-reviewed changes ...

Oleg.


                 reply	other threads:[~2007-02-10 21:50 UTC|newest]

Thread overview: [no followups] expand[flat|nested]  mbox.gz  Atom feed

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20070210215014.GA2210@tv-sign.ru \
    --to=oleg@tv-sign.ru \
    --cc=akpm@linux-foundation.org \
    --cc=dhowells@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®