From: Dave Jones <davej@redhat.com>
To: Venkatesh Pallipadi <venkatesh.pallipadi@intel.com>
Cc: linux-kernel <linux-kernel@vger.kernel.org>,
Andrew Morton <akpm@osdl.org>, Adam Belay <abelay@novell.com>,
Shaohua Li <shaohua.li@intel.com>,
Len Brown <len.brown@intel.com>
Subject: Re: [PATCH 1/3] Introducing cpuidle: core cpuidle infrastructure
Date: Mon, 12 Feb 2007 20:22:01 -0500 [thread overview]
Message-ID: <20070213012201.GA27685@redhat.com> (raw)
In-Reply-To: <20070212103925.A12078@unix-os.sc.intel.com>
On Mon, Feb 12, 2007 at 10:39:25AM -0800, Venkatesh Pallipadi wrote:
>
> Introducing 'cpuidle', a new CPU power management infrastructure to manage
> idle CPUs in a clean and efficient manner.
> cpuidle separates out the drivers that can provide support for multiple types
> of idle states and policy governors that decide on what idle state to use
> at run time.
> A cpuidle driver can support multiple idle states based on parameters like
> varying power consumption, wakeup latency, etc (ACPI C-states for example).
> A cpuidle governor can be usage model specific (laptop, server,
> laptop on battery etc).
> Main advantage of the infrastructure being, it allows independent development
> of drivers and governors and allows for better CPU power management.
>
> A huge thanks to Adam Belay and Shaohua Li who were part of this mini-project
> since its beginning and are greatly responsible for this patchset.
interesting. Though I wonder about giving admins _more_ knobs to twiddle.
It took cpufreq a long time to settle down in this area, and typically
'ondemand' was the answer in the end for 99.9% of people. I question the usefulness
for the whole multiple governors interface, because in the case of cpuidle
there shouldn't be any real trade-off between one algorithm and another afaics?
So why can't we just have one, that just 'does the right thing' ?
The only differentiator that I can think of would be latency, but that seems
to be a) covered in a different tunable, and b) probably wouldn't affect
most people enough where it matters.
I'll do a proper code review later, but one thing stuck out like a sore
thumb on a quick skim..
> +EXPORT_SYMBOL_GPL(current_driver);
That's a horribly generic name for an exported global.
current_cpuidle_driver maybe?
--
http://www.codemonkey.org.uk
next prev parent reply other threads:[~2007-02-13 1:22 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-02-12 18:39 Venkatesh Pallipadi
2007-02-13 1:22 ` Dave Jones [this message]
2007-02-13 7:58 ` Arjan van de Ven
2007-02-13 13:31 ` Venkatesh Pallipadi
2007-02-14 4:10 ` Adam Belay
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20070213012201.GA27685@redhat.com \
--to=davej@redhat.com \
--cc=abelay@novell.com \
--cc=akpm@osdl.org \
--cc=len.brown@intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=shaohua.li@intel.com \
--cc=venkatesh.pallipadi@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®