mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Ralf Baechle <ralf@linux-mips.org>
To: Takashi Iwai <tiwai@suse.de>
Cc: Andrew Morton <akpm@linux-foundation.org>,
	perex@suse.cz, alsa-devel@alsa-project.org,
	linux-kernel@vger.kernel.org
Subject: Re: [SOUND] hda_intel: build fix
Date: Mon, 12 Mar 2007 15:46:47 +0000	[thread overview]
Message-ID: <20070312154647.GC11974@linux-mips.org> (raw)
In-Reply-To: <s5hzm6ijzep.wl%tiwai@suse.de>

On Mon, Mar 12, 2007 at 03:43:10PM +0100, Takashi Iwai wrote:

> Fair enough.  I agree that removing const is the only reasonable fix
> right now.   But from semantics, const is a good thing, and people may
> try to add it again later if we get rid of them now.  So, how about to
> comment out such as /*const*/ in each place to remind that it's
> intentional?

I consider that harder to read and uglier.  If anything maybe something
like:

#define __const_devinit
[...]
static __const_devinit struct snd_kcontrol_new snd_ice1712_delta1010lt_wordclock_status __devinitdata =

Worth it?  I doubt.

> Also, in your patch to ice1712, you don't have to remove const from the
> codes in snd_ice1712_read_eeprom() and snd_ice1712_probe() functions.
> They should work as const pointer.

No, that results in warnings:

  CC      sound/pci/ice1712/ice1712.o
sound/pci/ice1712/ice1712.c: In function ‘snd_ice1712_read_eeprom’:
sound/pci/ice1712/ice1712.c:2354: warning: assignment from incompatible pointer type
sound/pci/ice1712/ice1712.c: In function ‘snd_ice1712_probe’:
sound/pci/ice1712/ice1712.c:2693: warning: assignment from incompatible pointer type

  Ralf

  reply	other threads:[~2007-03-12 15:48 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2007-03-10 19:05 Ralf Baechle
2007-03-10 19:26 ` [SOUND] ice1712: build fixes Ralf Baechle
2007-03-10 19:27   ` Ralf Baechle
2007-03-10 19:35 ` Ralf Baechle
2007-03-12 11:04 ` [SOUND] hda_intel: build fix Takashi Iwai
2007-03-12 13:53   ` Ralf Baechle
2007-03-12 14:43     ` Takashi Iwai
2007-03-12 15:46       ` Ralf Baechle [this message]
2007-03-12 16:38         ` Takashi Iwai
2007-03-13 12:42           ` Ralf Baechle

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20070312154647.GC11974@linux-mips.org \
    --to=ralf@linux-mips.org \
    --cc=akpm@linux-foundation.org \
    --cc=alsa-devel@alsa-project.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=perex@suse.cz \
    --cc=tiwai@suse.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome