mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Andrew Morton <akpm@linux-foundation.org>
To: Guennadi Liakhovetski <g.liakhovetski@gmx.de>
Cc: Bernhard Walle <bwalle@suse.de>,
	linux-kernel@vger.kernel.org,
	Thomas Gleixner <tglx@linutronix.de>, Ingo Molnar <mingo@elte.hu>
Subject: Re: [patch 0/7] Add IRQF_IRQPOLL_IRQ flag to allow irqpoll
Date: Mon, 26 Mar 2007 21:16:05 -0800	[thread overview]
Message-ID: <20070326211605.48a46957.akpm@linux-foundation.org> (raw)
In-Reply-To: <Pine.LNX.4.60.0703270700250.3960@poirot.grange>

On Tue, 27 Mar 2007 07:01:44 +0200 (CEST) Guennadi Liakhovetski <g.liakhovetski@gmx.de> wrote:

> On Sun, 25 Mar 2007, Bernhard Walle wrote:
> 
> > * Guennadi Liakhovetski <g.liakhovetski@gmx.de> [2007-03-24 00:21]:
> > > On Fri, 23 Mar 2007, Bernhard Walle wrote:
> > > 
> > > > * Guennadi Liakhovetski <g.liakhovetski@gmx.de> [2007-03-23 23:15]:
> > > > > On Fri, 23 Mar 2007, Bernhard Walle wrote:
> > > > > 
> > > > > > irqpoll is broken on some architectures that don't use the IRQ 0 for the timer
> > > > > > interrupt like IA64. This patch adds a IRQF_IRQPOLL_IRQ flag.
> > > > > 
> > > > > emn, please, cannot we come up with a better name - one that doesn't have 
> > > > > "IRQ" 3 (!) times in it?...
> > > > 
> > > > Well, it was suggested by Andrew. What's your suggestion?
> > > 
> > > Purely esthetically (ehm, am I saying that?...) your original suggestion 
> > > to use IRQF_IRQPOLL looks better to me. Or even IRQF_POLL, but, maybe, 
> > > it's a bit too much of a simplification.
> > 
> > I personally don't care very much about the naming. So I think it's
> > Andrews final decision ...
> 
> Sure. And for him to have a better chance to do this, I'll fix his email 
> address too:-)
> 

I don't think I went as daringly far as to suggest the full name, but I
must admit that IRQF_IRQPOLL_IRQ is actually logical.


      reply	other threads:[~2007-03-27  5:16 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2007-03-23 16:44 Bernhard Walle
2007-03-23 16:44 ` [patch 1/7] Add IRQF_IRQPOLL_IRQ flag (common code) Bernhard Walle
2007-03-23 16:44 ` [patch 2/7] Add IRQF_IRQPOLL_IRQ flag on IA64 Bernhard Walle
2007-03-23 16:44 ` [patch 3/7] Add IRQF_IRQPOLL_IRQ flag on x86_64 Bernhard Walle
2007-03-23 16:44 ` [patch 4/7] Add IRQF_IRQPOLL_IRQ flag on arm Bernhard Walle
2007-03-23 16:44 ` [patch 5/7] Add IRQF_IRQPOLL_IRQ flag on sh Bernhard Walle
2007-03-23 16:44 ` [patch 6/7] Add IRQF_IRQPOLL_IRQ flag on parisc Bernhard Walle
2007-03-23 16:44 ` [patch 7/7] Add IRQF_IRQPOLL_IRQ flag on i386 Bernhard Walle
2007-03-23 22:15 ` [patch 0/7] Add IRQF_IRQPOLL_IRQ flag to allow irqpoll Guennadi Liakhovetski
2007-03-23 22:25   ` Bernhard Walle
2007-03-23 23:21     ` Guennadi Liakhovetski
2007-03-25 20:29       ` Bernhard Walle
2007-03-27  5:01         ` Guennadi Liakhovetski
2007-03-27  5:16           ` Andrew Morton [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20070326211605.48a46957.akpm@linux-foundation.org \
    --to=akpm@linux-foundation.org \
    --cc=bwalle@suse.de \
    --cc=g.liakhovetski@gmx.de \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    --cc=tglx@linutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome