On Mon, May 07, 2007 at 10:31:32PM -0700, William Lee Irwin III wrote: >> I think Andi's handling the mergework on those patches, but I'll check >> in to see if I should rediff vs. -mm or what if you want them. >> Andi, what's the verdict on those stack patches? On Tue, May 08, 2007 at 10:59:50AM +0200, Andi Kleen wrote: > I planned to merge them partially. Add the separate 4/8/irqstack options, > add the vmalloc support, but not support the > 8K stacks. Haven't yet. I respun things to incorporate some of hch's suggestions and to fix an issue Jeremy Fitzhardinge had with CPU hotplug, and some suggestion from someone else, too. Basically what changed was: ( 1) drop the large stack config option patch entirely ( 2) fold the __pa() check into the vmalloc stack patch under #ifdef ( 3) rename CONFIG_VMALLOC_STACK to CONFIG_DEBUG_STACK ( 4) fold guarding CPU 0's IRQ stack into the vmalloc stack patch ( 5) make IRQ stacks unconditional instead of independently configurable ( 6) check slab_is_available() for CPU 0's bootmem vs. get_free_pages() ( 7) mark various things __cpuinit that needed to be ( 8) handle and propagate allocation errors up to __cpu_up() ( 9) redo CPU 0's IRQ stack allocation to normalize it for hotplug (10) use a struct for IRQ stack state instead of 3 per_cpu vars The current patch series needs the two fixup patches at the end folded back into the patches it fixes up, but follows in its entirety as a series of MIME attachments. I've no idea what it applies against. -- wli