From: Bjorn Helgaas <bjorn.helgaas@hp.com>
To: "Maciej W. Rozycki" <macro@linux-mips.org>
Cc: Yinghai Lu <yhlu.kernel@gmail.com>,
Gerd Hoffmann <kraxel@suse.de>, Andi Kleen <ak@suse.de>,
akpm@linux-foundation.org,
Linus Torvalds <torvalds@linux-foundation.org>,
"Eric W. Biederman" <ebiederm@xmission.com>,
linux kernel mailing list <linux-kernel@vger.kernel.org>
Subject: Re: [patch] early printk and boot console fixups.
Date: Thu, 17 May 2007 11:18:09 -0600 [thread overview]
Message-ID: <200705171118.09413.bjorn.helgaas@hp.com> (raw)
In-Reply-To: <Pine.LNX.4.64N.0705171038050.11098@blysk.ds.pg.gda.pl>
On Thursday 17 May 2007 03:45:36 am Maciej W. Rozycki wrote:
> On Wed, 16 May 2007, Bjorn Helgaas wrote:
> > > Given the generic name of "uart" I am assuming this will work with any
> > > UART driver making use of the serial_core.c core -- am I correct?
> >
> > I knew somebody would ask that eventually :-)
> >
> > Unfortunately, the answer is "no." "console=uart" only works with
> > 8250-compatible devices.
>
> But is it a design limitation or is it just that other UART drivers have
> to be modified to work with this option? My point is if the former, then
> the option should be something like "console=8250" (the right-hand side
> being the name of the driver involved; others may want to add support for
> other drivers). If the latter, then it's fine as is as other UART drivers
> may be wired to this code as a need arises.
"console=8250" probably would have been a better choice. I think
this could be changed without too much hassle.
It might be possible to extend "console=uart" so one could do
"console=uart,io,0x3f8,9600n8,21285" (where "21285" is a non-8250
UART type). But that seems ugly to me. I'd rather have
"console=21285", "console=68328", etc.
I just want the "console=<tag>" to explicitly identify the UART
type so we don't have to poke at the thing and guess what it is.
Bjorn
prev parent reply other threads:[~2007-05-17 17:18 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-02-16 14:49 Gerd Hoffmann
2007-05-16 4:17 ` Yinghai Lu
2007-05-16 15:59 ` Bjorn Helgaas
2007-05-16 16:29 ` Yinghai Lu
2007-05-16 16:56 ` Bjorn Helgaas
2007-05-16 17:09 ` Maciej W. Rozycki
2007-05-16 18:14 ` Bjorn Helgaas
2007-05-17 9:45 ` Maciej W. Rozycki
2007-05-17 16:54 ` Yinghai Lu
2007-05-17 17:18 ` Bjorn Helgaas [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=200705171118.09413.bjorn.helgaas@hp.com \
--to=bjorn.helgaas@hp.com \
--cc=ak@suse.de \
--cc=akpm@linux-foundation.org \
--cc=ebiederm@xmission.com \
--cc=kraxel@suse.de \
--cc=linux-kernel@vger.kernel.org \
--cc=macro@linux-mips.org \
--cc=torvalds@linux-foundation.org \
--cc=yhlu.kernel@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®