From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1765938AbXFEUbC (ORCPT ); Tue, 5 Jun 2007 16:31:02 -0400 Received: (majordomo@vger.kernel.org) by vger.kernel.org id S1764477AbXFEUaz (ORCPT ); Tue, 5 Jun 2007 16:30:55 -0400 Received: from havoc.gtf.org ([69.61.125.42]:44610 "EHLO havoc.gtf.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1763443AbXFEUay (ORCPT ); Tue, 5 Jun 2007 16:30:54 -0400 Date: Tue, 5 Jun 2007 16:30:48 -0400 From: Jeff Garzik To: "Keshavamurthy, Anil S" Cc: linux-kernel@vger.kernel.org, akpm@osdl.org, ak@suse.de, gregkh@suse.de, muli@il.ibm.com, asit.k.mallick@intel.com, suresh.b.siddha@intel.com, arjan@linux.intel.com, ashok.raj@intel.com, shaohua.li@intel.com, davem@davemloft.net Subject: Re: [Intel-IOMMU 02/10] Library routines for handling pre-allocated pool of objects Message-ID: <20070605203048.GR31565@havoc.gtf.org> References: <20070604210242.079459000@askeshav-devel.jf.intel.com> <20070604210644.156875000@askeshav-devel.jf.intel.com> <20070604225714.GM20299@havoc.gtf.org> <20070604230649.GB9948@linux-os.sc.intel.com> <20070604234354.GC31462@havoc.gtf.org> <20070604235105.GA13390@linux-os.sc.intel.com> <20070605202433.GA27638@linux-os.sc.intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20070605202433.GA27638@linux-os.sc.intel.com> User-Agent: Mutt/1.4.1i Sender: linux-kernel-owner@vger.kernel.org X-Mailing-List: linux-kernel@vger.kernel.org On Tue, Jun 05, 2007 at 01:24:33PM -0700, Keshavamurthy, Anil S wrote: > 1 file changed, 65 insertions(+), 19 deletions(-) > > Index: linux-2.6.22-rc3/lib/respool.c > =================================================================== > --- linux-2.6.22-rc3.orig/lib/respool.c 2007-06-05 12:22:26.000000000 -0700 > +++ linux-2.6.22-rc3/lib/respool.c 2007-06-05 12:58:01.000000000 -0700 > @@ -67,6 +67,7 @@ > { > unsigned long flags; > struct list_head *plist = (struct list_head *)vaddr; > + bool queue_work = 0; Seems sane to me. I only have a very minor nit to pick: naming a variable (queue_work) the same as a public function may cause confusion. Also, if its a bool you should initialize it to 'true' or 'false'. Jeff