From: Kristen Carlson Accardi <kristen.c.accardi@intel.com>
To: James Bottomley <James.Bottomley@SteelEye.com>
Cc: Jeff Garzik <jeff@garzik.org>,
linux-ide@vger.kernel.org, linux-scsi@vger.kernel.org,
linux-kernel@vger.kernel.org, htejun@gmail.com,
arjan@linux.intel.com
Subject: Re: [patch 2a/3] Expose Power Management Policy option to users
Date: Thu, 14 Jun 2007 09:39:52 -0700 [thread overview]
Message-ID: <20070614093952.c8ebef17.kristen.c.accardi@intel.com> (raw)
In-Reply-To: <1181748408.3421.7.camel@mulgrave.il.steeleye.com>
On Wed, 13 Jun 2007 08:26:48 -0700
James Bottomley <James.Bottomley@SteelEye.com> wrote:
> On Tue, 2007-06-12 at 10:46 -0700, Kristen Carlson Accardi wrote:
> > Expose Power Management Policy option to users
> >
> > This patch will modify the scsi subsystem to allow
> > users to set a power management policy for the link.
> >
> > The scsi subsystem will create a new sysfs file for each
> > host in /sys/class/scsi_host called "link_power_management_policy".
> > This file can have 3 possible values:
>
> I'm afraid the host isn't really the right place to put the link power
> management policy (assuming you want to manage the individual links
> separately) because there isn't a one to one correspondence between
> links and hosts.
>
> To take the model I understand: SAS; the links are managed at the phy
> level, so the power policy should be set there and thus should probably
> be a property of the phy object, which doesn't even exist in the SCSI
> model, it only exists in the transport class. It strikes me that even
> for ATA, the same thing is probably true.
>
> Now, I can see that the power management models of all the transports
> might share some similarities (particularly at this three stage granular
> level); if so, it might make sense to export helpers from the mid-layer
> for the transport classes to use for this.
Ok - sorry for my ignorance about SCSI - but my sources (i.e. Arjan) tell
me that the problem is that Link in ATA land means something different than
Link in SCSI land, and that what I really need to do is leave this code under
the Host class, but rename it to something that more accurately reflects
what it means under SCSI. So, is the word "segment" more appropriate?
Should I rename the file to "segment_power_management_policy"?
Thanks,
kristen
>
> > Value Meaning
> > -------------------------------------------------------------------
> > min_power User wishes the link to conserve power as much as
> > possible, even at the cost of some performance
> >
> > max_performance User wants priority to be on performance, not power
> > savings
> >
> > medium_power User wants power savings, with less performance cost
> > than min_power (but less power savings as well).
>
> These seem like nicely sane and generic values.
>
> James
>
next prev parent reply other threads:[~2007-06-14 16:44 UTC|newest]
Thread overview: 35+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <20070611184146.448266229@intel.com>
2007-06-11 18:48 ` [patch 1/3] Store interrupt value Kristen Carlson Accardi
2007-06-11 19:59 ` Jeff Garzik
2007-06-11 18:48 ` [patch 2/3] Expose Power Management Policy option to users Kristen Carlson Accardi
2007-06-11 20:00 ` Jeff Garzik
2007-06-12 17:46 ` [patch 2a/3] " Kristen Carlson Accardi
2007-06-13 15:26 ` James Bottomley
2007-06-13 20:48 ` Jeff Garzik
2007-06-14 16:39 ` Kristen Carlson Accardi [this message]
2007-06-14 17:44 ` Jeff Garzik
2007-06-12 17:47 ` [patch 2b/3] " Kristen Carlson Accardi
2007-06-20 21:22 ` Kristen Carlson Accardi
2007-06-11 18:48 ` [patch 3/3] Enable Aggressive Link Power management for AHCI controllers Kristen Carlson Accardi
2007-06-11 20:01 ` Jeff Garzik
2007-06-12 1:11 ` Henrique de Moraes Holschuh
2007-06-12 1:16 ` Arjan van de Ven
2007-06-12 1:54 ` Dagfinn Ilmari Mannsåker
2007-06-12 1:59 ` Jeff Garzik
2007-06-12 3:59 ` Henrique de Moraes Holschuh
2007-06-12 3:59 ` Arjan van de Ven
2007-06-12 9:09 ` Matthew Garrett
2007-06-12 12:18 ` Henrique de Moraes Holschuh
2007-06-12 13:50 ` Matthew Garrett
2007-06-12 14:17 ` Henrique de Moraes Holschuh
2007-06-12 15:38 ` Matthew Garrett
2007-06-12 15:45 ` Tejun Heo
2007-06-12 15:56 ` Matthew Garrett
2007-06-12 15:46 ` Jeff Garzik
2007-06-12 15:58 ` Matthew Garrett
2007-06-12 16:18 ` Jeff Garzik
2007-06-12 16:27 ` Kristen Carlson Accardi
2007-06-20 21:23 ` Kristen Carlson Accardi
2007-06-21 13:08 ` Jens Axboe
2007-06-22 17:15 ` Kristen Carlson Accardi
2007-06-22 19:00 ` Jens Axboe
2007-06-26 15:24 ` Kristen Carlson Accardi
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20070614093952.c8ebef17.kristen.c.accardi@intel.com \
--to=kristen.c.accardi@intel.com \
--cc=James.Bottomley@SteelEye.com \
--cc=arjan@linux.intel.com \
--cc=htejun@gmail.com \
--cc=jeff@garzik.org \
--cc=linux-ide@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-scsi@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®