mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Andrew Morton <akpm@linux-foundation.org>
To: Yoann Padioleau <padator@wanadoo.fr>
Cc: linux-janitors@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] potential parse error, drivers/serial/dz.h
Date: Mon, 16 Jul 2007 15:04:21 -0700	[thread overview]
Message-ID: <20070716150421.c21d38c5.akpm@linux-foundation.org> (raw)
In-Reply-To: <87k5t05r4a.fsf@wanadoo.fr>

On Mon, 16 Jul 2007 17:02:13 +0200
Yoann Padioleau <padator@wanadoo.fr> wrote:

> 
> potential parse error in declaration under a #ifdef.

A certain parse error, I'd say.  How come nobody is reporting it?
 
> Signed-off-by: Yoann Padioleau <padator@wanadoo.fr> 
> 
> 
> diff --git a/drivers/serial/dz.h b/drivers/serial/dz.h
> index 9674d4e..9141c37 100644
> --- a/drivers/serial/dz.h
> +++ b/drivers/serial/dz.h
> @@ -125,8 +125,8 @@ #define DZ_XMIT_SIZE   4096             
>  #define DZ_WAKEUP_CHARS   DZ_XMIT_SIZE/4
>  
>  #ifdef MODULE
> -int init_module (void)
> -void cleanup_module (void)
> +int init_module (void);
> +void cleanup_module (void);
>  #endif
>  
>  #endif /* DZ_SERIAL_H */

I don't think these symbols are actually implemented in anything which
uses this header.  If they _do_ exist then they are awfully named and
should be renamed ASAP.  Or they should be made static.

However I suspect they just don't exist, and this stuff should be simply
deleted.

  reply	other threads:[~2007-07-16 22:04 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2007-07-16 15:02 Yoann Padioleau
2007-07-16 22:04 ` Andrew Morton [this message]
2007-07-16 22:14   ` Robert P. J. Day

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20070716150421.c21d38c5.akpm@linux-foundation.org \
    --to=akpm@linux-foundation.org \
    --cc=linux-janitors@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=padator@wanadoo.fr \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®