From: "Rafael J. Wysocki" <rjw@sisk.pl>
To: Andrew Morton <akpm@linux-foundation.org>
Cc: LKML <linux-kernel@vger.kernel.org>,
Alan Stern <stern@rowland.harvard.edu>,
David Brownell <david-b@pacbell.net>,
Len Brown <len.brown@intel.com>,
Nigel Cunningham <nigel@nigel.suspend2.net>,
Pavel Machek <pavel@ucw.cz>, Shaohua Li <shaohua.li@intel.com>,
Johannes Berg <johannes@sipsolutions.net>,
Paul Mackerras <paulus@samba.org>,
Russell King <rmk@arm.linux.org.uk>
Subject: [Resend][PATCH 0/9] PM: Update global suspend and hibernation operations framework
Date: Tue, 17 Jul 2007 22:36:27 +0200 [thread overview]
Message-ID: <200707172236.28895.rjw@sisk.pl> (raw)
Hi,
This series of patches implements changes that are possible/necessary/desirable
(IMO) after the introduction of the .set_target() method in 'struct pm_ops' (commit
2391dae3e36c19fe668c71eac2eb8344dbaaf46d).
The patches in the series make the following changes:
* make ACPI use the new .set_target() method in 'struct pm_ops'
* add an ACPI helper function for the devices to determine the power state
to put the device into
* move the definition of 'struct pm_ops' to <include/suspend.h>
* change the name of 'struct pm_ops' to 'struct platform_suspend_ops' and
modify the names of some related functions and global variables accordingly
* modify 'struct platform_suspend_ops' so that .prepare() and .finish() don't
take arguments (.enter() still takes the state argument, because some
platforms don't need to implement the other callbacks)
* make some functions normally defined in kernel/power/main.c be also defined
when CONFIG_PM is unset
* make suspend_ops be a static variable
* rework 'struct hibernation_ops' to add the new method analogous to
.set_target()
* rename 'struct hibernation_ops' to 'struct platform_hibernation_ops' (in
analogy with 'struct platform_suspend_ops')
The series in on top of the current -git with the following patches, currently
in -mm or in the ACPI tree, applied:
swsusp-remove-incorrect-code-from-userc.patch
swsusp-remove-code-duplication-between-diskc-and-userc.patch
swsusp-introduce-restore-platform-operations.patch
swsusp-fix-hibernation-code-ordering.patch
hibernation-prepare-to-enter-the-low-power-state.patch
pm-introduce-hibernation-and-suspend-notifiers.patch
acpi-do-not-attempt-to-run-s1-standby-workarounds-while-hibernating.patch
pm-reduce-code-duplication-between-mainc-and-userc-updated.patch
Greetings,
Rafael
--
"Premature optimization is the root of all evil." - Donald Knuth
next reply other threads:[~2007-07-17 20:46 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-07-17 20:36 Rafael J. Wysocki [this message]
2007-07-17 20:40 ` [Resend][PATCH 1/9] ACPI: Implement the set_target() callback from pm_ops Rafael J. Wysocki
2007-07-18 0:02 ` Andrew Morton
2007-07-18 6:41 ` Rafael J. Wysocki
2007-07-19 2:05 ` Len Brown
2007-07-19 9:17 ` Rafael J. Wysocki
2007-07-21 19:26 ` David Brownell
2007-07-17 20:40 ` [Resend][PATCH 2/9] ACPI: Add acpi_pm_device_sleep_state helper routine Rafael J. Wysocki
2007-07-22 9:00 ` Len Brown
2007-07-17 20:42 ` [Resend][PATCH 3/9] PM: Move definition of struct pm_ops to suspend.h Rafael J. Wysocki
2007-07-17 20:43 ` [Resend][PATCH 4/9] PM: Rename struct pm_ops and related things Rafael J. Wysocki
2007-07-17 20:44 ` [Resend][PATCH 5/9] PM: Rework struct platform_suspend_ops Rafael J. Wysocki
2007-07-17 20:45 ` [Resend][PATCH 6/9] PM: Fix compilation of suspend code if CONFIG_PM is unset Rafael J. Wysocki
2007-07-17 20:46 ` [Resend][PATCH 7/9] PM: Make suspend_ops static Rafael J. Wysocki
2007-07-17 20:47 ` [Resend][PATCH 8/9] PM: Rework struct hibernation_ops Rafael J. Wysocki
2007-07-17 20:48 ` [Resend][PATCH 9/9] PM: Rename hibernation_ops to platform_hibernation_ops Rafael J. Wysocki
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=200707172236.28895.rjw@sisk.pl \
--to=rjw@sisk.pl \
--cc=akpm@linux-foundation.org \
--cc=david-b@pacbell.net \
--cc=johannes@sipsolutions.net \
--cc=len.brown@intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=nigel@nigel.suspend2.net \
--cc=paulus@samba.org \
--cc=pavel@ucw.cz \
--cc=rmk@arm.linux.org.uk \
--cc=shaohua.li@intel.com \
--cc=stern@rowland.harvard.edu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome