mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Oleg Verych <olecom@flower.upol.cz>
To: Valdis.Kletnieks@vt.edu
Cc: Joerg Roedel <joerg.roedel@amd.com>,
	Andi Kleen <andi@firstfloor.org>,
	Christoph Egger <Christoph.Egger@amd.com>,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/2] i386: mce cleanup part1: functional change
Date: Wed, 10 Oct 2007 03:58:08 +0200	[thread overview]
Message-ID: <20071010015807.GE22435@flower.upol.cz> (raw)
In-Reply-To: <1152.1191962806@turing-police.cc.vt.edu>

On Tue, Oct 09, 2007 at 04:46:46PM -0400, Valdis.Kletnieks@vt.edu wrote:
> On Tue, 09 Oct 2007 18:32:30 +0200, Oleg Verych said:
> > On Tue, Oct 09, 2007 at 06:06:05PM +0200, Joerg Roedel wrote:
> > > > cpu_has() returns int,
> > > > but would it be better to have something like
> > > > 
> > > >   	if (!mce_disabled &&
> > > > 	    !(c->x86_capability & (X86_FEATURE_MCA | X86_FEATURE_MCE)) {
> > > > 		printk(KERN_INFO "CPU%i: No machine check support available\n",
> > > > 			smp_processor_id());
> > > 
> > > This looks complicated and is harder to read. Its exactly the purpose of the
> > > cpu_has() macro to avoid such constructs.
> > 
> > It is done via test_bit(), which is designed for IO access with all that
> > `const volatile' stuff, 2 x unnecessary, can't be optimized here (IMHO).
> 
> If this code is getting called often enough that optimization matters, you
> got *bigger* issues to worry about than optimization.  Looks like it should
> only happen once at boot time.

Text size matters even on static storages. A Linuxbios image not fitting
to the 2M flash, etc.

Thanks.
____

  reply	other threads:[~2007-10-10  1:44 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2007-10-09 12:49 [PATCH 0/2] i386: MCE updates Joerg Roedel
2007-10-09 12:49 ` [PATCH 1/2] i386: mce cleanup part1: functional change Joerg Roedel
2007-10-09 16:04   ` Oleg Verych
2007-10-09 16:06     ` Joerg Roedel
2007-10-09 16:32       ` Oleg Verych
2007-10-09 16:54         ` Joerg Roedel
2007-10-09 20:46         ` Valdis.Kletnieks
2007-10-10  1:58           ` Oleg Verych [this message]
2007-10-09 17:33       ` coding for optimizations (Re: [PATCH 1/2] i386: mce cleanup part1: functional change) Oleg Verych
2007-10-09 18:30         ` Joerg Roedel
2007-10-10 23:14           ` Adrian Bunk
2007-10-11 15:26             ` Oleg Verych
2007-10-11 15:21               ` Adrian Bunk
2007-10-11 16:13                 ` Oleg Verych
2007-10-09 12:49 ` [PATCH 2/2] i386: mce cleanup part2: conding style cleanups Joerg Roedel

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20071010015807.GE22435@flower.upol.cz \
    --to=olecom@flower.upol.cz \
    --cc=Christoph.Egger@amd.com \
    --cc=Valdis.Kletnieks@vt.edu \
    --cc=andi@firstfloor.org \
    --cc=joerg.roedel@amd.com \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®