From: Muli Ben-Yehuda <muli@il.ibm.com>
To: Andi Kleen <ak@suse.de>
Cc: "H. Peter Anvin" <hpa@zytor.com>, Dave Jones <davej@redhat.com>,
Joerg Roedel <joerg.roedel@amd.com>,
Thomas Gleixner <tglx@linutronix.de>,
Ingo Molnar <mingo@redhat.com>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 4/4] x86 gart: rename symbols only used for the GART implementation
Date: Tue, 23 Oct 2007 21:18:41 +0200 [thread overview]
Message-ID: <20071023191841.GF4360@rhun.haifa.ibm.com> (raw)
In-Reply-To: <200710232010.55074.ak@suse.de>
On Tue, Oct 23, 2007 at 08:10:54PM +0200, Andi Kleen wrote:
> I think his goal was to get an prefix that describes the module
> uniquely. gart_* clearly does not fulfill that criteria.
>
> So basically he's replacing an
> ambigious-with-other-IOMMU-implementations prefix with an
> ambigious-with-AGP prefix. Seems like a rather pointless change.
Not at all - the present situation where GART specific code
masquerades as generic IOMMU code is confusing. I've heard from more
than one person who was confused by "how come I can enable an IOMMU
while CONFIG_IOMMU is off?" and "how come some iommu_xxx options
(which were really gart options...) don't actually affect the
(Calgary) IOMMU"?
If the variable names clash the correct solution is to s/gart/agpgart/
in the AGP code and then continue renaming gart specific bits 'gart'
rather than 'iommu'.
Cheers,
Muli
--
SYSTOR 2007 --- 1st Annual Haifa Systems and Storage Conference 2007
http://www.haifa.il.ibm.com/Workshops/systor2007/
Virtualization workshop: Oct 29th, 2007 | Storage workshop: Oct 30th, 2007
next prev parent reply other threads:[~2007-10-24 1:41 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-10-23 17:41 [PATCH 0/4] x86: some GART cleanups Joerg Roedel
2007-10-23 17:41 ` [PATCH 1/4] x86 gart: rename iommu.h to gart.h Joerg Roedel
2007-10-23 19:06 ` Muli Ben-Yehuda
2007-10-23 17:41 ` [PATCH 2/4] x86 gart: rename CONFIG_IOMMU to CONFIG_GART_IOMMU Joerg Roedel
2007-10-23 19:06 ` Muli Ben-Yehuda
2007-10-23 17:41 ` [PATCH 3/4] x86 gart: make some variables and functions static Joerg Roedel
2007-10-23 19:07 ` Muli Ben-Yehuda
2007-10-23 17:41 ` [PATCH 4/4] x86 gart: rename symbols only used for the GART implementation Joerg Roedel
2007-10-23 17:43 ` Andi Kleen
2007-10-23 17:47 ` Joerg Roedel
2007-10-23 17:59 ` Dave Jones
2007-10-23 18:04 ` H. Peter Anvin
2007-10-23 18:10 ` Andi Kleen
2007-10-23 19:05 ` Joerg Roedel
2007-10-23 19:18 ` Muli Ben-Yehuda [this message]
2007-10-24 10:49 [PATCH 0/4] x86: some GART cleanups Joerg Roedel
2007-10-24 10:49 ` [PATCH 4/4] x86 gart: rename symbols only used for the GART implementation Joerg Roedel
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20071023191841.GF4360@rhun.haifa.ibm.com \
--to=muli@il.ibm.com \
--cc=ak@suse.de \
--cc=davej@redhat.com \
--cc=hpa@zytor.com \
--cc=joerg.roedel@amd.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=tglx@linutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome