mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Nick Piggin <nickpiggin@yahoo.com.au>
To: Erez Zadok <ezk@cs.sunysb.edu>
Cc: hch@infradead.org, viro@ftp.linux.org.uk,
	akpm@linux-foundation.org, linux-kernel@vger.kernel.org,
	linux-fsdevel@vger.kernel.org
Subject: Re: [PATCH 36/42] VFS: export drop_pagecache_sb
Date: Fri, 14 Dec 2007 09:47:10 +1100	[thread overview]
Message-ID: <200712140947.11049.nickpiggin@yahoo.com.au> (raw)
In-Reply-To: <200712131524.lBDFOHBv024206@agora.fsl.cs.sunysb.edu>

On Friday 14 December 2007 02:24, Erez Zadok wrote:
> In message <200712121638.35167.nickpiggin@yahoo.com.au>, Nick Piggin writes:
> > On Monday 10 December 2007 13:42, Erez Zadok wrote:
> > > Needed to maintain cache coherency after branch management.
> >
> > Hmm, I'd much prefer to be able to sleep in invalidate_mapping_pages
> > before this function gets exported.
> >
> > As it is, it can cause massive latencies on preemption and the inode_lock
> > so it is pretty much debug-only IMO. I'd rather it didn't escape into the
> > wild as is.
> >
> > Either that or rework your cache coherency somehow.
>
> Nick, thanks for the advice.
>
> We use a generation number after each successful branch configuration
> command, so that ->d_revalidate later on can discover that change, and
> rebuild the union of objects.  At ->remount time, I figured it'd be nice to
> "encourage" that revalidation to happen sooner, by invalidating as many
> upper pages as possible, thus causing ->d_revalidate/->readpage to take
> place sooner.  So we used to call drop_pagecache_sb from our remount code:
> it was the only caller of drop_pagecache_sb.  It wasn't too much of an
> latency issue to call drop_pagecache_sb there: the VFS remount code path is
> already pretty slow (dropping temporarily to readonly mode, and dropping
> other caches), and remount isn't an operation used often, so a little bit
> more latency would probably not have been noticed by users.

Well a large, infrequent spike is the most damaging to latency sensitive
users. And anyway, I guess the infrequency of remount means it doesn't
have to be really efficient with invalidating pagecache either.


> Nevertheless, it was not strictly necessary to call drop_pagecache_sb in
> unionfs_remount, because the objects in question will have gotten
> revalidated sooner or later anyway; the call to drop_pagecache_sb was just
> an optimization (one which I wasn't 100% sure about anyway, as per my long
> "XXX" comment above that call in unionfs_remount).
>
> So I agree with you: if this symbol can be abused by modules and cause
> problems, then exporting it to modules is too risky.  I've reworked my code
> to avoid calling drop_pagecache_sb and I'll [sic] drop that patch.

Thanks, I'd be much happier with that.

  reply	other threads:[~2007-12-13 22:51 UTC|newest]

Thread overview: 54+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2007-12-10  2:41 [UNIONFS] 00/42 Unionfs and related patches review Erez Zadok
2007-12-10  2:41 ` [PATCH 01/42] Unionfs: filesystems documentation index Erez Zadok
2007-12-10 14:47   ` Jan Engelhardt
2007-12-13 15:06     ` Erez Zadok
2007-12-13 21:25       ` Jan Engelhardt
2007-12-10  2:41 ` [PATCH 02/42] Unionfs: unionfs " Erez Zadok
2007-12-10  2:41 ` [PATCH 03/42] Unionfs: documentation for general concepts Erez Zadok
2007-12-10  2:41 ` [PATCH 04/42] Unionfs: usage documentation for users Erez Zadok
2007-12-10  2:41 ` [PATCH 05/42] Unionfs: documentation for any known issues Erez Zadok
2007-12-10  2:41 ` [PATCH 06/42] Unionfs: documentation about renaming operations Erez Zadok
2007-12-10  2:41 ` [PATCH 07/42] Unionfs maintainers Erez Zadok
2007-12-10  2:41 ` [PATCH 08/42] Makefile: hook to compile unionfs Erez Zadok
2007-12-10  2:41 ` [PATCH 09/42] Unionfs: main Makefile Erez Zadok
2007-12-10  2:41 ` [PATCH 10/42] Unionfs: fanout header definitions Erez Zadok
2007-12-10  2:41 ` [PATCH 11/42] Unionfs: main header file Erez Zadok
2007-12-10  2:41 ` [PATCH 12/42] Unionfs: common file copyup/revalidation operations Erez Zadok
2007-12-10  2:41 ` [PATCH 13/42] Unionfs: basic file operations Erez Zadok
2007-12-10  2:41 ` [PATCH 14/42] Unionfs: lower-level copyup routines Erez Zadok
2007-12-10  2:41 ` [PATCH 15/42] Unionfs: dentry revalidation Erez Zadok
2007-12-10  2:41 ` [PATCH 16/42] Unionfs: lower-level lookup routines Erez Zadok
2007-12-10  2:41 ` [PATCH 17/42] Unionfs: rename method and helpers Erez Zadok
2007-12-10  2:41 ` [PATCH 18/42] Unionfs: directory reading file operations Erez Zadok
2007-12-10  2:41 ` [PATCH 19/42] Unionfs: readdir helper functions Erez Zadok
2007-12-10  2:41 ` [PATCH 20/42] Unionfs: readdir state helpers Erez Zadok
2007-12-10  2:41 ` [PATCH 21/42] Unionfs: inode operations Erez Zadok
2007-12-10  2:41 ` [PATCH 22/42] Unionfs: unlink/rmdir operations Erez Zadok
2007-12-10  2:41 ` [PATCH 23/42] Unionfs: address-space operations Erez Zadok
2007-12-10  2:41 ` [PATCH 24/42] Unionfs: mount-time and stacking-interposition functions Erez Zadok
2007-12-10  2:41 ` [PATCH 25/42] Unionfs: super_block operations Erez Zadok
2007-12-10  2:41 ` [PATCH 26/42] Unionfs: extended attributes operations Erez Zadok
2007-12-10  2:42 ` [PATCH 27/42] Unionfs: async I/O queue headers Erez Zadok
2007-12-10  2:42 ` [PATCH 28/42] Unionfs: async I/O queue operations Erez Zadok
2007-12-10  2:42 ` [PATCH 29/42] Unionfs: miscellaneous helper routines Erez Zadok
2007-12-10  2:42 ` [PATCH 30/42] Unionfs: debugging infrastructure Erez Zadok
2007-12-10  2:42 ` [PATCH 31/42] VFS: fs_stack header cleanups Erez Zadok
2007-12-10  2:42 ` [PATCH 32/42] Unionfs file system magic number Erez Zadok
2007-12-10  2:42 ` [PATCH 33/42] MM: extern for drop_pagecache_sb Erez Zadok
2007-12-10 14:04   ` Adrian Bunk
2007-12-13 15:05     ` Erez Zadok
2007-12-10  2:42 ` [PATCH 34/42] VFS path get/put ops used by Unionfs Erez Zadok
2007-12-10  2:42 ` [PATCH 35/42] Unionfs: common header file for user-land utilities and kernel Erez Zadok
2007-12-10  2:42 ` [PATCH 36/42] VFS: export drop_pagecache_sb Erez Zadok
2007-12-12  5:38   ` Nick Piggin
2007-12-13 15:24     ` Erez Zadok
2007-12-13 22:47       ` Nick Piggin [this message]
2007-12-10  2:42 ` [PATCH 37/42] VFS: export release_open_intent symbol Erez Zadok
2007-12-10  2:42 ` [PATCH 38/42] VFS: simplified fsstack_copy_attr_all Erez Zadok
2007-12-10  2:42 ` [PATCH 39/42] Put Unionfs and eCryptfs under one layered filesystems menu Erez Zadok
2007-12-10  2:42 ` [PATCH 40/42] eCryptfs: use simplified fs_stack API for dentry operations Erez Zadok
2007-12-10  2:42 ` [PATCH 41/42] eCryptfs: use simplified fs_stack API for inode operations Erez Zadok
2007-12-10  2:42 ` [PATCH 42/42] eCryptfs: use simplified fs_stack API for main operations Erez Zadok
2007-12-10  3:20 ` [UNIONFS] 00/42 Unionfs and related patches review hooanon05
2007-12-13 15:29   ` Erez Zadok
2007-12-14 21:15     ` hooanon05

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=200712140947.11049.nickpiggin@yahoo.com.au \
    --to=nickpiggin@yahoo.com.au \
    --cc=akpm@linux-foundation.org \
    --cc=ezk@cs.sunysb.edu \
    --cc=hch@infradead.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=viro@ftp.linux.org.uk \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®