From: Haavard Skinnemoen <hskinnemoen@atmel.com>
To: "Andrew Victor" <avictor.za@gmail.com>
Cc: "Remy Bohmer" <linux@bohmer.net>,
linux-kernel@vger.kernel.org,
"ARM Linux Mailing List"
<linux-arm-kernel@lists.arm.linux.org.uk>,
"Russell King - ARM Linux" <linux@arm.linux.org.uk>
Subject: Re: [PATCH]: Atmel Serial Console interrupt handler splitup
Date: Tue, 18 Dec 2007 11:29:07 +0100 [thread overview]
Message-ID: <20071218112907.609cc013@dhcp-252-066.norway.atmel.com> (raw)
In-Reply-To: <cd73a99e0712180208x73eb1095qbea96f1a9746298b@mail.gmail.com>
On Tue, 18 Dec 2007 12:08:05 +0200
"Andrew Victor" <avictor.za@gmail.com> wrote:
> > #define at_readl(port, off) __raw_readl((port)->membase + (off))
> > #define at_writel(v, port, off) __raw_writel(v, (port)->membase + (off))
> >
> > #define UART_PUT_CR(port, v) at_writel(v, port, ATMEL_US_CR)
> > #define UART_PUT_MR(port, v) at_writel(v, port, ATMEL_US_MR)
>
> I'd like to point out this relatively recent change to CodingStyle.
> http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=dff4982f5cd4e30e2a140a3bca95d8814115bf5b
>
> So I don't see a reason for complicating the code by adding additional
> macro's just to fit it in 80 column's.
Hmm...yes, I think that change to the CodingStyle makes sense. But I
guess the question is whether the old code "significantly increases
readability" and whether the new code "hides information".
I don't think so, but I don't feel all that strongly about it. I'd
actually prefer if we used at_writel() and at_readl() throughout the
code and killed those UART_PUT/UART_GET macros.
Haavard
next prev parent reply other threads:[~2007-12-18 10:30 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <3efb10970712070724i6fa66666t2b8422329759ce24@mail.gmail.com>
[not found] ` <Pine.LNX.4.58.0712121606241.23712@gandalf.stny.rr.com>
[not found] ` <3efb10970712121429l7b41d57md4f826f6aaf4b71@mail.gmail.com>
[not found] ` <3efb10970712130840r7a2c5f72jca641d1cac545464@mail.gmail.com>
[not found] ` <cd73a99e0712130933s6f601ef7sed90f48c08d9adaa@mail.gmail.com>
[not found] ` <3efb10970712131232j5f747420g4aa8b5bd956e3dd3@mail.gmail.com>
[not found] ` <3efb10970712131235t47a9ceb5y7d9a7d5023d07bf6@mail.gmail.com>
[not found] ` <3efb10970712140346l1845d563k900d72d8788ac6f5@mail.gmail.com>
2007-12-17 12:17 ` Haavard Skinnemoen
2007-12-17 18:13 ` Haavard Skinnemoen
2007-12-17 20:56 ` Remy Bohmer
2007-12-17 23:12 ` Haavard Skinnemoen
2007-12-18 7:32 ` Remy Bohmer
2007-12-17 23:49 ` Russell King - ARM Linux
2007-12-18 9:07 ` Haavard Skinnemoen
[not found] ` <cd73a99e0712180208x73eb1095qbea96f1a9746298b@mail.gmail.com>
2007-12-18 10:29 ` Haavard Skinnemoen [this message]
2007-12-18 11:53 ` Remy Bohmer
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20071218112907.609cc013@dhcp-252-066.norway.atmel.com \
--to=hskinnemoen@atmel.com \
--cc=avictor.za@gmail.com \
--cc=linux-arm-kernel@lists.arm.linux.org.uk \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@arm.linux.org.uk \
--cc=linux@bohmer.net \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®